Bug 119486 - Selinux with ReiserFS
Selinux with ReiserFS
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-doc (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 16:22 EST by Les Addison
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-06 20:23:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Les Addison 2004-03-30 16:22:51 EST
Description of problem: Installed FC Test2 with ReiserFS and Selinux
at default Active setting. Upon installation completion and reboot
system generates continuous scrolling messages with avc errors.
Messages scroll to rapidly to read exact text. These scrolling
messages never stop and the system does not continue to boot beyond
this point. Reinstallation using all of the same options but with ext3
file systems works as expected.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Boot from CD and at boot prompt enter linux reiserfs
2. Select reiserfs for disk partitions and Active for Selinux
3. Complete install and reboot
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2004-03-30 17:24:06 EST
reiserfs does not support extended attributes, so SELinux will not
work with it. I believe you need to use either ext3 or XFS.
Comment 2 Toshio Kuratomi 2004-05-23 19:47:30 EDT
It looks like kernel 2.6.7 has patches from SuSE to reiserfs3 that
allow xattrs, including the ones necessary for SELinux.

Note You need to log in before you can comment on or make changes to this bug.