Bug 119495 - LTC7133-/sbin/init error messages when using IUCV for installation
LTC7133-/sbin/init error messages when using IUCV for installation
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
s390 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-03-30 17:02 EST by Mark Ver
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-11 22:54:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mark Ver 2004-03-30 17:02:36 EST
The following has be reported by IBM LTC:  
/sbin/init error messages when using IUCV for installation
Hardware Environment:
Manufacturer:         IBM
Type:                 2064
Model:                109
VM00 Control Program: z/VM    4.4.0

Software Environment:
r--r--r--    4 root     root           44 Mar 16 22:11 generic.prm
-rw-r--r--    4 root     root      5890684 Mar 16 22:11 initrd.img
-rwxr-xr-x    4 root     root      3993344 Mar 16 22:11 kernel.img

Steps to Reproduce:
1.  Download the 3 RedHat U2 bootstrap files to VM guest
2.  Load the files to VM reader and IPL from reader to start bootstrap 
3.  Specify "iucv" as your network type 
4.  Continue until after the point where you specify your IUCV partner 

Actual Results:
After specifying the iucv partner, you see the following messages:
/sbin/init: line 1: cut: command not found            
/sbin/init: line 216: [: !=: unary operator expected  
IUCV lowlevel driver Version:  initialized 

A check of /sbin/init (which links to /linuxrc) on the ramdisk, we 
find that the 
target line is as follows:
        if [ $(echo "$IUCV" |cut -c 1-5) != "iucv=" ]; then
The problem is that the "cut" command isn't available on the ramdisk.

Expected Results:
The /linuxrc functions correctly and no error messages are displayed.

Additional Information:
One possible solution ... using awk in place of cut:
        if [ $(echo "$IUCV" |awk -F= '{print $1"="}') != "iucv=" ]; 
Not sure how well this would work with the /linuxrc environme
Comment 1 Karsten Hopp 2004-03-31 04:35:33 EST
we're using bash, so this should work: 
if [ "${IUCV:0:5}" = "iucv=" ]; then 
Comment 2 Jeremy Katz 2004-04-02 18:49:11 EST
Fixed in CVS, will be in final U2 build.
Comment 3 John Flanagan 2004-05-11 22:48:52 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

Comment 4 Mark Ver 2004-05-13 14:36:18 EDT
While trying out the current errata, I kept getting the following 
    IUCV lowlevel driver Version:  initialized               
    netiucv: Invalid delimiter '='                                    
    divert: not allocating divert_blk for non-ethernet device iucv0   
    iucv0: 'iucv'                                                     
    NETIUCV driver Version: 1.21  initialized                         
    iucv0: User iucv is currently not available.         

I didn't realize it before, but the proposed code has a typo.
Basically the line
    if [ "${IUCV:0:5}" = "iucv=" ]; then
should really read as
    if [ "${IUCV:0:5}" != "iucv=" ]; then

Comment 5 Jeremy Katz 2004-06-08 12:06:04 EDT
Fixed for U3
Comment 6 IBM Bug Proxy 2004-11-11 16:53:53 EST
----- Additional Comments From markver@us.ibm.com  2004-11-11 16:51 EDT -------
Verified fixed on RHEL-3 Update 3 and on RHEL-3 Update 4 beta1, ex:
   Enter iucv kernel module options (usually iucv=HOST,
   where HOST is TCPIP for the VM TCP/IP service machine
   or the name (in capital letters) of another          
   Linux guest:
   IUCV lowlevel driver Version:  initialized             
   divert: not allocating divert_blk for non-ethernet device iucv0 
   iucv0: 'TCPIP'                                                  
   NETIUCV driver Version: 1.21  initialized                       
   iucv0: connected with remote side                               
   Enter your DNS server(s), separated by colons (:): 

Marking bug closed. 

Note You need to log in before you can comment on or make changes to this bug.