Bug 119500 - Openssl not detected - krb5 required and not found
Openssl not detected - krb5 required and not found
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openssl (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 17:45 EST by Graham Leggett
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 12:05:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2004-03-30 17:45:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
When cups v1.1.20 as supplied by www.cups.org is built under RHEL3,
openssl is not detected. config.log says this:

configure:8915: checking openssl/ssl.h usability
configure:8928: gcc -c -O2 -g -pipe -march=i386 -mcpu=i686  conftest.c >&5
In file included from /usr/include/openssl/ssl.h:179,
                 from configure:9011:
/usr/include/openssl/kssl.h:72:18: krb5.h: No such file or directory
In file included from /usr/include/openssl/ssl.h:179,
                 from configure:9011:
/usr/include/openssl/kssl.h:134: syntax error before "krb5_enctype"
/usr/include/openssl/kssl.h:136: syntax error before '*' token

The problem is that krb5.h, referenced from ssl.h, is not found. This
file lives here:

/usr/kerberos/include/krb5.h

The path /usr/kerberos/include is not included in the CFLAGS by cups
(why should cups care about /usr/kerberos/include?), and so ssl is
therefore not detected.

To fix this, the include of krb5.h should be made optional, or krb5.h
should be installed in /usr/include like everything else.


Version-Release number of selected component (if applicable):
openssl-0.9.7a-33.4

How reproducible:
Always

Steps to Reproduce:
xxx

Additional info:
Comment 1 Sam Fewster 2004-04-16 09:49:41 EDT
This also seems to happen on other compiles of progs that require ssl.

I normally use the following:

export CFLAGS=-I/usr/kerberos/include
Comment 2 nathan r. hruby 2004-05-25 08:42:31 EDT
METOO.  Building things with openssl gets broken.

Can we at least have the %configure or %makeinstall macro in rpmbuild
pass in the correct CFLAGS?
Comment 3 Richard Homolka 2004-10-15 11:54:37 EDT
Try adding:
-DOPENSSL_NO_KRB5
to CFLAGS
Comment 4 Tom "spot" Callaway 2004-10-15 12:05:56 EDT
I'm not sure this one is Red Hat's fault. It looks like a custom
package that you're building isn't using -I/usr/kerberos/include in
its CFLAGS, which, if you're building your own RPM, is easy enough to
add. Alternately, the cups rpm that Red Hat built, uses this routine
in its spec:

if pkg-config openssl ; then
  export CFLAGS=`pkg-config --cflags openssl`
  export CPPFLAGS=`pkg-config --cflags-only-I openssl`
  export LDFLAGS=`pkg-config --libs-only-L openssl`
fi

You could add this to the spec of any custom RPM that breaks.

Closing as NOTABUG.
Comment 5 nathan r. hruby 2004-10-15 12:17:17 EDT
Well, yeah, I know how to fix it :)  

Maybe this needs to be an rpm buglet instead.  What'd be nice if there
was an RPM macro that did the above constuct correctly for you instead
of having to repeat it for eevery package you build.

FWIW, the krb linked to openssl has been a buglet for a while. I jsut
forget about it a lot ;)

Note You need to log in before you can comment on or make changes to this bug.