Bug 119502 - Installer does not enable Realtek 8139 chipset ethernet card
Installer does not enable Realtek 8139 chipset ethernet card
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 17:59 EST by Christopher Ostmo
Modified: 2014-03-16 22:43 EDT (History)
1 user (show)

See Also:
Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 17:00:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from 'kudzu -p -b pci' (2.67 KB, text/plain)
2004-03-30 21:48 EST, Christopher Ostmo
no flags Details

  None (edit)
Description Christopher Ostmo 2004-03-30 17:59:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
Ugraded from RH 9.0 on an AMD Athlon.  Card in question worked in RH
9.0.  'lspci' showed the card.  The card was not dispalyed in the
network config GUI's "hardware" tab.  The card DID show up under
"Network devices" in the Hardware Browser.

Problem fixed by adding to modules.conf and modprobe.conf:
alias eth0 8139too



Version-Release number of selected component (if applicable):
Fedora Core 2 Test 2

How reproducible:
Always

Steps to Reproduce:
Install, boot computer.
    

Additional info:

Linksys PCI wireless network adapter (Prism 2.5 Wavelan chipset) that
never worked under RH 9.0 was detected, intalled, enabled and worked
without any intervention.

The problem with the Realtek 8139 chipset card was fixable, but should
be enabled by the installer as it was in RH 9.0.
Comment 1 Bill Nottingham 2004-03-30 21:38:12 EST
What's the output of 'kudzu -p -b pci'?
Comment 2 Christopher Ostmo 2004-03-30 21:48:23 EST
Created attachment 98987 [details]
output from 'kudzu -p -b pci'

Attached is the output from the requested command.

Note: This command was run AFTER I added the 'alias eth0 8139too' line to
modules.conf.

I am pretty sure that this command would have shown the card prior to the
modification of modules.conf since 'lspci' showed that the card was present and
recognized by the OS.
Comment 3 Christopher Ostmo 2004-03-30 22:01:04 EST
One more note because I though you might ask:

This shows the modules that were loaded after modifying modules.conf
(and modprobe.conf):

# lsmod | grep 8139
8139too                22016  0
mii                     3712  1 8139too
crc32                   3968  1 8139too

Although 8139too.o was present on the system, it did not load until I
added a line to modules.conf.

These loaded automatically after installation/upgrade (wireless):
# lsmod | grep orinoco
orinoco_pci             5644  0
orinoco                44684  1 orinoco_pci
hermes                  6656  2 orinoco_pci,orinoco

The installation process added a line to modules.conf to automatically
load the orinoco_pci module drivers (even though I had never setup
this card under RH 9).

I am relatively confident that the Realtek card was detected properly
by the system - it showed up in lspci and in the network config GUI's
Hardware Browser under "Network devices."  It seems that the failure
lies in the fact that the 8139too module failed to load automatically
after installation.  Perhaps the installer was supposed to add a line
to modules.conf for this device?

Thanks!
Comment 4 Christopher Ostmo 2004-03-30 22:04:15 EST
Woops - I didn't mean "network config GUI's Hardware Browser."

I just meant "Hardware Browser" - the one that's on the "System Tools"
menu in KDE.

Sorry.
Comment 5 Bill Nottingham 2004-08-27 18:46:41 EDT
Please try the test rpms at:

http://people.redhat.com/notting/kudzu/
Comment 6 Bill Nottingham 2005-09-23 17:00:11 EDT
Closing this bug. This should be fixed in FC4, if not earlier.

Note You need to log in before you can comment on or make changes to this bug.