Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1195030

Summary: Changing rpc to 'json-rpc' fails with, "Operation Failed: [Internal Engine Error]", due to errors on character encoding
Product: Red Hat Enterprise Virtualization Manager Reporter: rhev-integ
Component: ovirt-engine-restapiAssignee: Piotr Kliczewski <pkliczew>
Status: CLOSED ERRATA QA Contact: Jiri Belka <jbelka>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 3.5.0CC: bazulay, ecohen, gklein, juan.hernandez, lsurette, oourfali, pkliczew, rbalakri, Rhev-m-bugs, yeylon, ylavi
Target Milestone: ---Keywords: ZStream
Target Release: 3.5.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: infra
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1170125
: 1195147 1195148 (view as bug list) Environment:
Last Closed: 2015-04-28 18:47:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1170125    
Bug Blocks: 1193058, 1195147, 1195148, 1197441    

Comment 2 Jiri Belka 2015-03-16 16:00:53 UTC
ok, rhevm-3.5.1-0.1.el6ev.noarch

- added a host as xmlrpc, then maintenance, then change to 'json' (failed as expected: "The reason for this is that "json" isn't a valid value for "protocol", currently it must be "xml", "stomp" or "amqp".), then 'stomp' and it worked. host was activated successfully.

Comment 3 errata-xmlrpc 2015-04-28 18:47:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2015-0888.html