Bug 119506 - Output redirection to $HOME/.xsession-errors is a bad idea under SELinux
Summary: Output redirection to $HOME/.xsession-errors is a bad idea under SELinux
Status: CLOSED DUPLICATE of bug 119204
Alias: None
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords: SELinux
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-03-30 23:20 UTC by Aleksey Nogin
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aleksey Nogin 2004-03-30 23:20:38 UTC
The way the Xsession script is currently written, it defaults to
redictecting output to $HOME/.xsession-errors (unless the Gnome
session is selected). This file gets created with the default user
permissions and certain programs (ssh-agent, for example) end up not
being able to write to it and becoming very unhappy (ssh-agent starts
eating all the CPU). If the /tmp/xses-... is used, everything is OK.

I see 3 possible solutions:
a) Always use /tmp/xses-...
b) Change the script to have the $HOME/.xsession-errors created with
the tmp file SELinux context
c) Allow all those programs to write to user files (bad idea, obviously).

Bug 119204 addresses the same problem with the Xsession script shipped
in kdebase (and bug 119503 asks for that second script to be dropped
and the xinitrc one to be used instead).

Comment 1 Aleksey Nogin 2004-04-01 12:29:10 UTC
Now that kdebase no longer has a separate Xsession, this became a dup
of bug  119204.

*** This bug has been marked as a duplicate of 119204 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:02:17 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.