Bug 1195217 - Activation key example of subsription-manager to contain org label not name
Summary: Activation key example of subsription-manager to contain org label not name
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.0.7
Hardware: All
OS: All
low
medium
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-23 12:07 UTC by Pavel Moravec
Modified: 2017-08-01 20:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 20:34:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Pavel Moravec 2015-02-23 12:07:21 UTC
Description of problem:
Opening an activation key, there is a blue-box with a help like:

"
This activation key may be used during system registration. For example:

subscription-manager register --org="Default_Organization" --activationkey="RHN Activation Key"
"

The "--org=.." part refers to organization name instead of its label. While subscription-manager must point to the label.

This makes troubles when one changes a name of an organization (while its label stays unchanged). Since then, the help above is wrong.


Version-Release number of selected component (if applicable):
Sat 6.0.7.


How reproducible:
100%


Steps to Reproduce:
1. Change name of Default_Organization to anything else (e.g. "testOrg".
2. Create an activation key and check the blue box.


Actual results:
The blue box has --org="testOrg".


Expected results:
The blue box to have --org="Default_Organization"


Additional info:

Comment 2 Bryan Kearney 2016-07-08 20:31:59 UTC
Per 6.3 planning, moving out non acked bugs to the backlog

Comment 4 Bryan Kearney 2017-08-01 20:34:53 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.