Bug 1195269 (CVE-2015-8902) - CVE-2015-8902 ImageMagick: denial of service flaw in PDB file processing
Summary: CVE-2015-8902 ImageMagick: denial of service flaw in PDB file processing
Status: CLOSED CURRENTRELEASE
Alias: CVE-2015-8902
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20150219,reported=2...
Keywords: Security
Depends On: 1195270
Blocks: 1195276
TreeView+ depends on / blocked
 
Reported: 2015-02-23 13:57 UTC by Martin Prpič
Modified: 2019-06-08 20:26 UTC (History)
17 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-09-22 12:49:42 UTC


Attachments (Terms of Use)

Description Martin Prpič 2015-02-23 13:57:26 UTC
A denial of service flaw (infinite loop) was found in the way ImageMagick processed certain PDB files:

http://seclists.org/oss-sec/2015/q1/608

Upstream issue, including a reproducer:

http://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=26932

A patch is not yet available as noted in comment 2 of the above-linked issue.

Comment 1 Martin Prpič 2015-02-23 13:58:01 UTC
Created ImageMagick tracking bugs for this issue:

Affects: fedora-all [bug 1195270]

Comment 2 Jodie Cunningham 2015-03-03 18:35:34 UTC
A patch for this issue in IM6 should be available here: http://trac.imagemagick.org/changeset/17855

Comment 3 Fedora Update System 2015-03-15 10:53:17 UTC
ImageMagick-6.8.8.10-9.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Adam Mariš 2016-06-07 08:19:22 UTC
CVE assignment:

http://seclists.org/oss-sec/2016/q2/481


Note You need to log in before you can comment on or make changes to this bug.