Bug 119527 - K Menu tends to hang
K Menu tends to hang
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 21:53 EST by Benjamin Thompson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-15 11:35:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Thompson 2004-03-30 21:53:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
When using KDE, there is often a long wait involved in getting the K
menu or any of its sub-menus to appear. Then, once appearing, the menu
can take a lot of time disappearing when clicking off of its field.
This doesn't happen for me in GNOME. Sometimes, hitting the ALT key or
ALT-TABing my way to an app causes the menu to finally disappear. When
it isn't exhibiting this behavior, the menu system behaves very
slowly. At worst, this is a usability issue where something somewhere
needs to get optimized a little.

How reproducible:
Sometimes

Steps to Reproduce:
1. Clicking on the K Menu
2. Try to navigate to a sub-menu or try to click off of the menu's
field to get rid of the menu.
3. Wait!
    
Actual Results:  The menu will frequently hang, or the system itself
will hang until the menu appears--sometimes until ALT or ALT-TAB is
pressed. Mouse movement is still possible.

Expected Results:  Swift appearance/disappearance of the menu.

Apologies if this bug isn't a kdebase bug, but it occurs only in KDE
and  with high frequency. I am uncertain what else this might be
symptomatic of.
Comment 1 Riku Seppala 2004-04-18 13:30:42 EDT
Same thing here, but I'm using fedora core 1. The problem first
appeared when I updated to kde 3.2.1
Comment 2 Ngo Than 2004-11-15 11:35:14 EST
sorry, it cannot reproduce this problem with FC3. it works for me.
Benjamin, could you please verify it with FC3? Thanks

Note You need to log in before you can comment on or make changes to this bug.