Bug 1195271 (CVE-2015-8903) - CVE-2015-8903 ImageMagick: denial of service flaw in VICAR file processing
Summary: CVE-2015-8903 ImageMagick: denial of service flaw in VICAR file processing
Status: CLOSED CURRENTRELEASE
Alias: CVE-2015-8903
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20150219,reported=2...
Keywords: Security
Depends On: 1195274
Blocks: 1195276
TreeView+ depends on / blocked
 
Reported: 2015-02-23 13:59 UTC by Martin Prpič
Modified: 2019-06-08 20:26 UTC (History)
16 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-09-22 12:49:33 UTC


Attachments (Terms of Use)

Description Martin Prpič 2015-02-23 13:59:33 UTC
A denial of service flaw (infinite loop) was found in the way ImageMagick processed certain VICAR files:

http://seclists.org/oss-sec/2015/q1/608

Upstream issue, including a reproducer:

http://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=26933

A patch is not yet available as noted in comment 2 of the above-linked issue.

Comment 1 Martin Prpič 2015-02-23 14:01:24 UTC
Created ImageMagick tracking bugs for this issue:

Affects: fedora-all [bug 1195274]

Comment 2 Jodie Cunningham 2015-03-03 18:33:22 UTC
A patch should be available for IM6 in http://trac.imagemagick.org/changeset/17856

Comment 3 Fedora Update System 2015-03-15 10:53:19 UTC
ImageMagick-6.8.8.10-9.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Adam Mariš 2016-06-07 08:19:56 UTC
CVE assignment:

http://seclists.org/oss-sec/2016/q2/481


Note You need to log in before you can comment on or make changes to this bug.