This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 119528 - Evolution won't launch and cannot be installed
Evolution won't launch and cannot be installed
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 22:03 EST by Chris Tooley
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-20 16:15:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Tooley 2004-03-30 22:03:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
After upgrading from Fedora Core 2 Test 1 to Test 2 Evolution stopped
working saying that it could not find libgal.  An apt-get
--fix-missing later and it was uninstalled and cannot be reinstalled
because of missing libsoup.

Version-Release number of selected component (if applicable):
evolution-1.5

How reproducible:
Always

Steps to Reproduce:
1.Install FC2 T1
2.Upgrade to FC2 T2
3.Try to Launch Evolution
    

Actual Results:  evolution stopped working

Expected Results:  being able to read my e-mail

Additional info:
Comment 1 Scott Sloan 2004-03-31 01:00:42 EST
This is because FC2 T2 doesn't ship with 1.5.x it reverts back to
1.4.6 in order to make the migration backwards follow this post

http://lists.ximian.com/archives/public/evolution/2004-February/035535.html

which is a complete headache. You can get the latest builds though
from Jeremy Katz site. just update yum.conf to... 

[evolution]
name=Evolution snaps
basurl=http://people.redhat.com/katzj/evolution/

But this is not a bug.
Comment 2 Chris Tooley 2004-03-31 08:16:52 EST
Ok, so why was it that evolution-1.4 wouldn't even launch on my FC2 T2
installation?
Comment 3 Scott Sloan 2004-04-05 01:00:56 EDT
because if you used evolution-1.5 in test 1 It did an update on all
your files to convert them to the new format in 1.5. If you carried
that same  /home/%user/.evolution profile over to the test 2 install
1.4.6 doesn't know how to read these new formats and would crash. 

this is my guess at what is happening. (Just as guess) You can always
run evolution from the command line and it should produce some out put
for you to give you a starting block. 
Comment 4 Maxwell Bottiger 2004-04-06 11:30:24 EDT
I'm having the same problems with evolution.  I have 1.5.3-1 from test
2, and that's the version I still have.  Upgrading to test 2 did not
downgrade my copy.  When I run it from the command line I get the
following error:

[sleepylight@host65-239 ~]$ evolution
evolution: error while loading shared libraries: libgal-2.2.so.0:
cannot open shared object file: No such file or directory

libgal2 is installed in version 1.99.11-1 on my system, but as part of
that version there isn't any file called libgal-2.2.so.0.  I guess
maybe this was removed from test2.

I think I found an rpm that provides it from the Ximian group off of
rpmfind.net, so I'm going to give that a shot.
Comment 5 Dave Malcolm 2004-09-20 16:00:33 EDT
I'm sorry that this bug hasn't been looked at in a while.  The test
builds of evolution referred to above are getting pretty old now,
evolution-1.5.94.1 is in rawhide (and evolution-2.0.0 should arrive in
the next few days; it's pretty stable for me).

So are any of you still having problems with this (can I help?), or
can I close this bug?
Comment 6 Scott Sloan 2004-09-20 16:05:36 EDT
I think this can be closed. it's been working fine for me
Comment 7 Dave Malcolm 2004-09-20 16:15:32 EDT
That's good to hear - resolving as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.