Bug 119530 - vnc.so causes xorg X server to crash
vnc.so causes xorg X server to crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-03-30 23:14 EST by Paul Iadonisi
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.0-1.beta5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-26 13:12:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Iadonisi 2004-03-30 23:14:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040115 Galeon/1.3.13

Description of problem:
Started with a Fedora Core 2 Test 1 system and kept it updated with
yum right through upgrading to Fedora Core 2 Test 2, including
manually enabling selinux (in relaxed mode).

I have a 'Load vnc' line in my XF86Config file and X keeps crashing as
a result.  Commenting out that line allows the xorg X server to start.
 Also, downgrading to vnc-server-4.0-1.beta4.8.1 fixes the problem so
it appears that vnc-4.0-1.beta4.9 is the culprit.

lspci output is:

00:00.0 Host bridge: Intel Corp. 82810E DC-133 GMCH [Graphics Memory
Controller Hub] (rev 03)
00:01.0 VGA compatible controller: Intel Corp. 82810E DC-133 CGC
[Chipset Graphics Controller] (rev 03)
00:1e.0 PCI bridge: Intel Corp. 82801AA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corp. 82801AA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801AA IDE (rev 02)
00:1f.2 USB Controller: Intel Corp. 82801AA USB (rev 02)
00:1f.3 SMBus: Intel Corp. 82801AA SMBus (rev 02)
01:07.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 09)
01:0c.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado]
(rev 78)


Version-Release number of selected component (if applicable):
vnc-4.0-1.beta4.9

How reproducible:
Always

Steps to Reproduce:
1.Add 'Load vnc' line to "Module" section in /etc/X11/XF86Config
2.Restart X

    

Actual Results:  X keeps crashing with a sig11.  Nothing more
informative is listed in the /var/log/XFree86.0.log file.

Expected Results:  X server should start with vnc :0 server enabled.

Additional info:
Comment 1 William Hooper 2004-03-31 21:16:13 EST
It crashes right as the X server is starting?

I've just done a fresh install of FC2Test2 and it seems to be working:

[whooper@poit whooper]$ rpm -q vnc-server
vnc-server-4.0-1.beta4.9
[whooper@poit whooper]$ rpm -q xorg-x11
xorg-x11-0.0.6.6-0.0.2004_03_11.9
[whooper@poit whooper]$

I see that there are some xorg updates from Rawhide that I don't have yet.
Comment 2 Tim Waugh 2004-04-01 03:38:40 EST
Even if vnc.so does work in some situations, Xvnc doesn't work at all.
 I've backed out the change ('build against xorg-x11') in
4.0-1.beta4.10 until I can figure it out.
Comment 3 mark 2004-05-21 23:32:09 EDT
on Fedora Core 2 with kernel 2.6.6-1.368...

i'm trying to connect using vnc from chrisf53 (192.168.2.5) to markf78
(192.168.2.2). i've opened ports 5900 and 5901 in the firewall on 
markf78 to allow vnc traffic to enter.

selinux is disabled in both systems.

[root@chrisf53 root]# rpm -qa | grep vnc*
vnc-4.0-1.beta5.1

[root@markf78 root]# rpm -qa | grep vnc*
vnc-4.0-1.beta5.1
vnc-server-4.0-1.beta5.1

in my /etc/X11/xorg.conf on "markf78", i added:

Load  "vnc" to Section "Module"
Option "passwordFile" "/root/.vnc/passwd" to Section "Screen"

[root@markf78 root]# more /etc/sysconfig/vncservers
# The VNCSERVERS variable is a list of display:user pairs.
#
# Uncomment the line below to start a VNC server on display :1
# as my 'myusername' (adjust this to your own).  You will also
# need to set a VNC password; run 'man vncpasswd' to see how
# to do that.
#
# DO NOT RUN THIS SERVICE if your local area network is
# untrusted!  For a secure way of using VNC, see
# <URL:http://www.uk.research.att.com/vnc/sshvnc.html>.
 
VNCSERVERS="1:root"
VNCSERVERARGS[1]="-geometry 800x600"
[root@markf78 root]#

[root@chrisf53 root]# vncviewer 192.168.2.2
 
VNC viewer for X version 4.0b5 - built May 20 2004 10:53:23
Copyright (C) 2002-2004 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
 
Fri May 21 22:31:26 2004
 CConn:       connected to host 192.168.2.2 port 5900
 CConnection: Server supports RFB protocol version 3.7
 CConnection: Using RFB protocol version 3.7
 
Fri May 21 22:31:35 2004
 TXImage:     Using default colormap and visual, TrueColor, depth 16.
 CConn:       Using pixel format depth 6 (8bpp) rgb222
 CConn:       Using ZRLE encoding

(system crashes including kernel)

[root@chrisf53 root]# ssh 192.168.2.2
ssh: connect to host 192.168.2.2 port 22: No route to host
[root@chrisf53 root]# ping 192.168.2.2
PING 192.168.2.2 (192.168.2.2) 56(84) bytes of data.
From 192.168.2.5 icmp_seq=0 Destination Host Unreachable
From 192.168.2.5 icmp_seq=1 Destination Host Unreachable
From 192.168.2.5 icmp_seq=2 Destination Host Unreachable
 
--- 192.168.2.2 ping statistics ---
3 packets transmitted, 0 received, +3 errors, 100% packet loss, time
2006ms
, pipe 4
Comment 4 mark 2004-05-21 23:39:19 EDT
per comment 3, please update Fedora Core version from "test2" to
"devel". vnc-4.0-1.beta5.1 is the latest version in rawhide as of this
writing 21 May 04.

per comment 3, please change severity from "normal" to "high".
VNC is not only hanging the Xserver but the linux kernel as well!

btw, i forgot to mention that i altered my XF86Config to parallel the
changes in xorg.conf due to "http://www.realvnc.com/v4/x0.html"
(outdated???) although i am assuming this file is now ignored with the
transition to xorg. 
Comment 5 Tim Waugh 2004-05-24 07:14:35 EDT
If you are using the VNC package from FC2 you need to open a different
bug.  THIS bug is about integration with xorg-x11, which was backed
out for release.

Open the new bug against 'kernel', since kernel crashes are kernel
bugs.  Thanks.
Comment 6 mark 2004-05-26 13:01:51 EDT
i've opened
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=124448 to
describe the bug i mentioned above.
Comment 7 Tim Waugh 2004-05-26 13:12:29 EDT
VNC integrated with xorg-x11 in 4.0-1.beta5.2.
Comment 8 Radu Cornea 2004-05-28 01:37:38 EDT
I have the same problem with vnc-server. After I installed vnc-server
4.0-1.beta5.2.i386 the X server keeps crashing and after a number of
tries it is disabled. Do I need to update anything else from
development to make it work?
Comment 9 Paul Iadonisi 2004-05-28 02:00:36 EDT
Yup, confirmed.  Looks like this second attempt to switch xorg-x11
still didn't work :-(  Let me know if you need any more info, let me
know.  My hardware is the same as in the original report.  Downgrading
to 4.0-1.beta5.1 makes it work again.
Comment 10 Radu Cornea 2004-05-28 02:37:44 EDT
Where can I find version 4.0-1.beta5.1?
Comment 11 Tim Waugh 2004-05-28 02:56:06 EDT
4.0-1.beta5.3 (which will be available later today) fixes this server
crash.

However, see bug #124589. :-(
Comment 12 Radu Cornea 2004-05-28 13:21:16 EDT
With 4.0-1.beta5.3, I get this errors when dri is enabled:

May 28 10:15:36 mars kernel: [drm:r128_cce_idle] *ERROR* r128_cce_idle
called without lock held
May 28 10:15:36 mars kernel: [drm:r128_cce_reset] *ERROR*
r128_cce_reset called without lock held
May 28 10:15:36 mars kernel: [drm:r128_cce_start] *ERROR*
r128_cce_start called without lock held
May 28 10:15:36 mars kernel: [drm:r128_cce_idle] *ERROR* r128_cce_idle
called without lock held
May 28 10:15:36 mars kernel: [drm:r128_cce_reset] *ERROR*
r128_cce_reset called without lock held
May 28 10:15:36 mars kernel: irq 11: nobody cared! (screaming interrupt?)
May 28 10:15:36 mars kernel: Call Trace:
May 28 10:15:36 mars kernel:  [<021070c9>] __report_bad_irq+0x2b/0x67
May 28 10:15:36 mars kernel:  [<02107161>] note_interrupt+0x43/0x66
May 28 10:15:36 mars kernel:  [<02107327>] do_IRQ+0x109/0x169
May 28 10:15:36 mars kernel:  [<0211af64>] __do_softirq+0x2c/0x73
May 28 10:15:36 mars kernel:  [<021078f5>] do_softirq+0x46/0x4d
May 28 10:15:36 mars kernel:  =======================
May 28 10:15:36 mars kernel:  [<0210737b>] do_IRQ+0x15d/0x169
May 28 10:15:36 mars kernel: 
May 28 10:15:36 mars kernel: handlers:
May 28 10:15:36 mars kernel: [<0221522d>] (usb_hcd_irq+0x0/0x4b)
May 28 10:15:36 mars kernel: Disabling IRQ #11

When dri is disabled, vnc works fine. I am using FC2 with kernel
2.6.5-1.358, graphic card ATI Rage Fury Pro (r128).
Comment 13 Tim Waugh 2004-05-28 13:26:33 EDT
Do you get that when don't have vnc.so loaded?  If so, please file a
bug against the 'kernel' component.
Comment 14 Radu Cornea 2004-05-28 13:46:16 EDT
No, I never got that before. Only with vnc.so. And in this latest
version I am able to remotely log on and kill X, which takes about
100% of CPU. Before, the whole system would crash. x0vncserver works
though, with this command:

x0vncserver PasswordFile=/root/.vnc/passwd rfbport=5900
Comment 15 Tim Waugh 2004-05-28 13:49:53 EDT
Can you file a separate bug report against vnc please?  I don't think
this is related to the original problem in this report.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.