Bug 119540 - Gnome's volume control shows multiple entries for SiS sound card
Gnome's volume control shows multiple entries for SiS sound card
Status: CLOSED DUPLICATE of bug 119732
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-31 03:53 EST by Eugenia Loli-Queru
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugenia Loli-Queru 2004-03-31 03:53:28 EST
Description of problem:

This one is a weird one. So, I got this fully supported SiS-based AMD 
Duron 1.3 GHz PC and it works fine. Its sound card is an SiS-based 
onboard sound card and it is fully supported by ALSA. I have 
installed Linare, Xandros, Mandrake 10 and Fedora on this machine, 
and all support the sound card.

The problem with Fedora2-test2 though, is that Gnome's volume manager 
shows TWO entries for this sound card, while it is only one card. I 
understand that one is for OSS and the other one is for Alsa, 
however, if you check out my screenshot here:
http://www.osnews.com/img/6443/audio.png
you will see that the SiS entry (the one marked as "Alsa Mixer") has 
DUPLICATE controls. I get two Line-in controls, I get two CD, two 
Mic, two Phone, two Video etc etc 
From what I remember, Mandrake's Gnome didn't exhibit this problem 
(also with kernel 2.6.x but with gnome 2.4.2).

So, this is quite annoying having useless duplicate entries of the 
controls, plus having that C-Media entry for OSS, while the system-
config-soundcard utility (also in the screenshot) only finds 
(correctly) a single sound card, the SiS one.

In the screenshot I have also included the "lspci -v" information for 
the sound card, just in case you need its specs.

Version-Release number of selected component (if applicable):


How reproducible:
Every Time.

Steps to Reproduce:
1. Launch gnome's volume control.
2.
3.
  
Actual results:
Gnome's volume control finds two different sound cards (while there 
is only one) but even worse, the correct sound card's controls are 
all duplicated.

Expected results:
To not have duplicated entries in the volume control for my Alsa  
sound card.

Additional info:
Comment 1 Colin Walters 2004-09-16 13:13:06 EDT
Yeah, it's a big problem, we've been talking about how to rewrite it.

*** This bug has been marked as a duplicate of 119732 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:17 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.