This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 119544 - Alt-F2 to step through compiler errors terminates xemacs suddenly.
Alt-F2 to step through compiler errors terminates xemacs suddenly.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xemacs (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-31 05:45 EST by Rob Clack
Modified: 2007-04-18 13:05 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 20:17:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rob Clack 2004-03-31 05:45:18 EST
Description of problem:
After compiling a C program I use Alt-F2 to step through the errors. 
To do this, I've disabled the desktop manager's keyboard shortcuts
that use Alt-F1 and F2 and bound compile to Alt-F1 and next-error to
Alt-F2.  This used to work OK with RH7.3 and in fact works fine with
RH9 most of the time, but sometimes instead of stepping through the
errors, xemacs just shuts down completely.  I used to think this was
when I only have compiler warnings and linker errors, since as long as
I have compiler errors it seems OK.  However, when I tried to make a
noddy app to demonstrate it, stepping through the warnings and linker
errors worked perfectly.

Version-Release number of selected component (if applicable):
xemacs 21.4

How reproducible:
Tricky.  Sigh.  I used to work in support and I know if I don't tell
you how to reliably reproduce it, it's next to impossible for you to
fix it.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
xemacs closes unexpectedly

Expected results:
app steps through compiler warnings and errors

Additional info:
Comment 1 Rob Clack 2004-03-31 05:59:34 EST
Not sure this really is i386.  It's a new(is) Compaq deskpro.

This is not caused by the desktop window manager interfering with my
keyboard shortcuts, since it also happens if I Alt-x next-error.
Comment 2 Rob Clack 2004-03-31 06:19:26 EST
It is i386 and I see, in /usr/lib xemacs-21.4.12 which is a bit more
precise than the 21.4 you get from Help About.
Comment 3 Jens Petersen 2004-04-01 06:36:13 EST
Any chance you could try with a newer xemacs like 21.4.15 say?

If uninstall your xemacs, install the latest xemacs-sumo rpm from
rawhide and rebuild the latest xemacs srpm and run that you should
be able to test it.
Comment 4 Rob Clack 2004-04-14 11:22:06 EDT
Been on holiday for a week, hence the delay.  New version 21.4.15
installed and appears to fix the problem.  Not completely convinced
yet, as I've not given it much of a hammering, but it's looking good
so far.  Thanks!
Comment 5 Jens Petersen 2004-04-14 20:17:16 EDT
Ok, I'll close for now: please re-open if you see the problem again.

Note You need to log in before you can comment on or make changes to this bug.