Bug 1195456 - Init scripts don't work for read only file systems
Summary: Init scripts don't work for read only file systems
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: samba
Version: 6.8
Hardware: All
OS: All
unspecified
medium
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-23 21:20 UTC by Serge Droz
Modified: 2015-07-22 07:20 UTC (History)
4 users (show)

Fixed In Version: samba-3.6.23-15.el6
Doc Type: Bug Fix
Doc Text:
Samba did not start when the file system was in read-only mode. With this update, the Samba init scripts no longer require write permissions for certain system files. Samba now runs as expected on read-only systems. (BZ#1195456)
Clone Of:
Environment:
Last Closed: 2015-07-22 07:20:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1383 normal SHIPPED_LIVE samba bug fix update 2015-07-20 18:07:43 UTC

Description Serge Droz 2015-02-23 21:20:03 UTC
Description of problem:
The init scripts for smb and nmb check if they are executed as root by checking if they can write to a file in /etc. If the filesystem is readonly this fails and samba wont start. 

Version-Release number of selected component (if applicable):

samba-3.6.23-14.el6_6.x86_64

How reproducible:


Steps to Reproduce:
1. Put the system into ro mode (/etc/sysconfig/read-only)
2. reboot
3. 

Actual results:
Samba is not runing

Expected results:
Samba running

Additional info:

The fix is easy:

replace the line containing 
[ -w /etc/samba/smb.conf ] || exit 4
by 
[  `id -u` -eq  "0" ] ||  exit 4

in /etc/init.d/{smb,nmb}

Comment 6 errata-xmlrpc 2015-07-22 07:20:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1383.html


Note You need to log in before you can comment on or make changes to this bug.