Bug 119547 - Installing will hang the machine/Kernel panic: Fatal exception in interrupt
Summary: Installing will hang the machine/Kernel panic: Fatal exception in interrupt
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Target
TreeView+ depends on / blocked
 
Reported: 2004-03-31 11:47 UTC by Ralph Mengen
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: test3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-29 08:42:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of the cmd lspci -vvv (8.42 KB, text/plain)
2004-03-31 11:48 UTC, Ralph Mengen
no flags Details
/proc/modules, /proc/scsi/scsi, /proc/cpuinfo (2.13 KB, text/plain)
2004-03-31 11:51 UTC, Ralph Mengen
no flags Details
kernel BUG at mm/slab.c:1808! Process mke2fs (2.08 KB, text/plain)
2004-04-01 09:15 UTC, Ralph Mengen
no flags Details
kernel BUG at mm/slab.c:1808! Process pdflush (5.64 KB, text/plain)
2004-04-01 09:16 UTC, Ralph Mengen
no flags Details
kernel BUG at mm/slab.c:1808! Process anaconda (5.70 KB, text/plain)
2004-04-01 09:17 UTC, Ralph Mengen
no flags Details
kernel BUG at mm/slab.c:2013! Process kswapd0 (4.59 KB, text/plain)
2004-04-01 09:20 UTC, Ralph Mengen
no flags Details
Attachment for text above. (I will never learn bugzilla.) (7.73 KB, text/plain)
2004-04-01 11:46 UTC, Ralph Mengen
no flags Details

Description Ralph Mengen 2004-03-31 11:47:00 UTC
Description of problem:
Installing Fedora Core 2 Test 2 on my PC will freeze my PC when trying
to create a filesystem.

Version-Release number of selected component (if applicable):
(see attached files)

How reproducible:
Everytime I install the system the installer will hang when starting
to install the selected components.
When I select 'format disk' it will hang when starting to create the
filesystem.
When I don't select 'format disk' it starts to install the packages.
After some packages the system freezes.

When I boot from CD/DVD and go into rescue mode (or use the normal
installer and go to another console) and try to 'mkefs' a partition
the system will hang with something like:

Stack: c24d9bfc 00000000 ....
Call Trace:
[<c01501a5>] drain_array+0xd20x16a
...
...          do_softirq...
=======================
...          do_IRQ....
...
...          start_kernel...

Code: 0f ...
 <0> Kernel panic: Fatal exception in interrupt
In interrupt handler - not syning

(If you really need the whole text, drop me a line and I will type in
that whole page!)

The system runs without any real problem with WindowsXP, Mandrake 10
and RedHat 9!

Comment 1 Ralph Mengen 2004-03-31 11:48:03 UTC
Created attachment 98993 [details]
Output of the cmd lspci -vvv

Comment 2 Ralph Mengen 2004-03-31 11:51:55 UTC
Created attachment 98994 [details]
/proc/modules, /proc/scsi/scsi, /proc/cpuinfo

Comment 3 Dave Jones 2004-03-31 13:08:44 UTC
yes, the whole panic text is needed.


Comment 4 Arjan van de Ven 2004-03-31 13:12:30 UTC
(we don't need the hex numbers tho, only the names)

Comment 5 Ralph Mengen 2004-04-01 09:15:09 UTC
Created attachment 99030 [details]
kernel BUG at mm/slab.c:1808! Process mke2fs

Comment 6 Ralph Mengen 2004-04-01 09:16:28 UTC
Created attachment 99031 [details]
kernel BUG at mm/slab.c:1808! Process pdflush

Comment 7 Ralph Mengen 2004-04-01 09:17:55 UTC
Created attachment 99032 [details]
kernel BUG at mm/slab.c:1808! Process anaconda

Comment 8 Ralph Mengen 2004-04-01 09:20:00 UTC
Created attachment 99033 [details]
kernel BUG at mm/slab.c:2013! Process kswapd0

I hope that this weren't too much files!
This panic is a little different from the others...

Comment 9 Arjan van de Ven 2004-04-01 10:04:47 UTC
hmmm
how much memory do you have?
does this go away if you pass "mem=xxxM" on the kernel commandline
(that very first prompt in the installer) (where xxx is the amount of
memory you have in megabytes minus 32)

Comment 10 Ralph Mengen 2004-04-01 11:44:22 UTC
The machine has 2GB memory.
The mem-trick doesn't (also with mem=800) help. The same problem as
always....

But this time I was able to say dmesg (see attachment 'dmesg.txt')
after the installer freezes (thanks to the guys who made that serial
console stuff) and this notes a 'DMA timeout', which I can't believe,
because this happens on a second machine we have, too!

Maybe it's a problem of the S-ATA stuff inside the kernel?


Comment 11 Ralph Mengen 2004-04-01 11:46:33 UTC
Created attachment 99034 [details]
Attachment for text above. (I will never learn bugzilla.)

Comment 12 Ralph Mengen 2004-04-03 19:46:20 UTC
I did some tests and now I think it's the kernel.

I installed Fedora Core 1 on the PC. The PC is stable with this.
Then I installed kernel-2.6.3-2.1.253.2.1.i686.rpm from 'Core 2 Test
2' on the machine and the problem described above starts to happen again!

Then I installed kernel-2.6.4-1.303.i686.rpm (plus glibc-2.3.3-20 and
friends) from the development directory and the machine seems to be
stable now. (OK there are some warning about USB and other stuff, but
this seems to be because the rest of the system is for kernel 2.4....)

So if anyone promises me that the final Fedore Core 2 will contain at
least that kernel-2.6.4-1.303.i686.rpm I would state this problem as
solved. :-)

P.S.: Yes, that is also true for the SMP-version!


Comment 13 Ralph Mengen 2004-04-29 08:42:27 UTC
I installed FC2 test3 (which uses kernel 2.6.5) and the problem is fixed!
 



Note You need to log in before you can comment on or make changes to this bug.