Bug 119551 - flac-xmms vs xmms-flac
flac-xmms vs xmms-flac
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: flac (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-03-31 07:24 EST by Dams
Modified: 2014-03-16 22:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 05:48:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2004-03-31 07:24:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.4.1)
Gecko/20031114 Galeon/1.3.13

Description of problem:
there is a flac-xmms package actually in development tree. This
package is a subpackage of the main flac package.
Problem is both freshrpms and fedora.us provides an xmms-flac package
that obsoletes flac-xmms.

Why this choice ? Because we decided plugins/modules of something
should be named as "something-pluginname". So all xmms plugins are
xmms-pluginname : xmms-flac, xmms-mp3, xmms-alsa, xmms-faad, etc.

I suggest the flac-xmms package in development tree is renamed to
xmms-flac and obsoletes flac-xmms.
Comment 1 Warren Togami 2004-04-05 03:07:15 EDT
flac in fedora.us builds against id3lib while FC does not ship it.  I
am not certain if it is important for the FLAC user experience.  Anvil
do you know?
Comment 2 Dams 2004-04-05 05:06:10 EDT
flac *was* using id3 format to add comment in the audio file. Now flac
is using ogg style comment. The only part that requires id3lib is the
xmms plugin to be able to read comments from old flac files with id3
inside.
Comment 4 Warren Togami 2004-04-05 05:48:41 EDT
hmm, nevermind, building without id3lib.

Note You need to log in before you can comment on or make changes to this bug.