Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1195545 - Terminal fails to start with "Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0"
Summary: Terminal fails to start with "Error constructing proxy for org.gnome.Terminal...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-terminal
Version: 22
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F22AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-02-24 03:40 UTC by Adam Williamson (Fedora)
Modified: 2015-05-04 19:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-24 17:50:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam Williamson (Fedora) 2015-02-24 03:40:16 UTC
This seems to be one of those 'greatest hits' bugs. There's a current case for F21, but I thought it'd be best to report separately for F22 as well. F21 bug is https://bugzilla.redhat.com/show_bug.cgi?id=1193311 .

After doing 'dnf update' today on an F22 install, I get this when trying to run gnome-terminal (from an Xfce Terminal window so I can see the error, but it fails to launch any way I try):

Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 1

This looks like an Alpha blocker:

"It must be possible to run the default web browser and a terminal application from all release-blocking desktop environments." - https://fedoraproject.org/wiki/Fedora_22_Alpha_Release_Criteria#Required_applications , though I need to check if it's reproducible with a clean install, this is on my messy production desktop install.

Comment 1 Matthias Clasen 2015-02-24 04:29:29 UTC
Needless to say, gnome-terminal works just fine here... could you perhaps be convinced to divulge the n-v-r of the gnome-terminal and vte packages this happened with ?  "after an update today" is not exactly precise enough to figure out what you were trying to run.

Some more questions: Is /usr/libexec/gnome-terminal-server running ? if not, what happens when you try to launch it manually ?

Comment 2 Adam Williamson (Fedora) 2015-02-24 04:58:40 UTC
whoops, sorry, closed this out before I meant to.

Happens with both gnome-terminal 3.14.2-2.fc22.x86_64 and 3.15.90-1.fc22.x86_64 . vte-0.28.2-14.fc22.x86_64 and vte3-0.36.3-3.fc22.x86_64 . 

gnome-terminal-server was not running; if I start it manually it runs fine, and I can then launch gnome-terminal successfully. What should be starting it?

Comment 3 Stephen Gallagher 2015-02-24 14:41:28 UTC
Adam, what version of GDM do you have running? There was a bug that snuck through until yesterday late morning that was breaking dbus-activated services (gnome-terminal included).

gdm-3.15.90.4-1.fc22.x86_64 fixed it for me (requires a reboot)

Comment 4 Matthias Clasen 2015-02-24 15:40:44 UTC
the gnome-terminal frontend should activate it on the bus - whats likely happening is that you have that gdm version that managed to not propagate DISPLAY into the activation environment

Comment 5 Adam Williamson (Fedora) 2015-02-24 16:39:28 UTC
It's a bingo - I have gdm-3.15.90.3-1.fc22.x86_64 . Thanks guys, I'll update and confirm that fixes it.

Comment 6 Adam Williamson 2015-02-24 17:50:25 UTC
Yup, that does the job. Thanks.


Note You need to log in before you can comment on or make changes to this bug.