Bug 1195663 - FTBFS: QEMU Driver error : internal error: hugepage backing not supported by '/usr/bin/qemu'
Summary: FTBFS: QEMU Driver error : internal error: hugepage backing not supported by ...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 22
Hardware: powerpc
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michal Privoznik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened, Upstream
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2015-02-24 10:09 UTC by Karsten Hopp
Modified: 2015-03-31 20:27 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-03-31 20:27:47 UTC


Attachments (Terms of Use)
build.log (211.01 KB, text/plain)
2015-02-24 10:09 UTC, Karsten Hopp
no flags Details

Description Karsten Hopp 2015-02-24 10:09:10 UTC
Created attachment 994642 [details]
build.log

Description of problem:
libvirt unit test fail on ppc*:
FAIL: qemuxml2argvtest
....
68) QEMU XML-2-ARGV hugepages-pages6                                  ... libvirt: QEMU Driver error : internal error: hugepage backing not supported by '/usr/bin/qemu'
FAILED



Version-Release number of selected component (if applicable):
libvirt-1.2.12-2.fc22

How reproducible:
always

Steps to Reproduce:
1. ppc-koji build --scratch f22 libvirt-1.2.12-2.fc22.src.rpm
2.
3.

Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2371768

Comment 1 Michal Privoznik 2015-02-24 15:54:50 UTC
This is fixed upstream, and it's going to be part of the upcoming release[1]:

commit b38da58423f44035e259e18a35853c16267ec83a
Author:     Daniel P. Berrange <berrange@redhat.com>
AuthorDate: Mon Feb 2 05:26:49 2015 -0500
Commit:     Daniel P. Berrange <berrange@redhat.com>
CommitDate: Mon Feb 2 20:27:43 2015 +0000

    Make tests independant of system page size
    
    Some code paths have special logic depending on the page size
    reported by sysconf, which in turn affects the test results.
    We must mock this so tests always have a consistent page size.

v1.2.13-rc1~132

1: https://www.redhat.com/archives/libvir-list/2015-February/msg00912.html

Comment 2 Cole Robinson 2015-02-24 16:10:23 UTC
Since this is a build failure, I'll keep the bug open until a working build is added to f22/rawhide


Note You need to log in before you can comment on or make changes to this bug.