Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1195668 - Perf: DHT errors filling logs when perf tests are run.
Summary: Perf: DHT errors filling logs when perf tests are run.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Raghavendra G
QA Contact:
URL:
Whiteboard:
Depends On: 1195378
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-24 10:24 UTC by Raghavendra G
Modified: 2015-05-14 17:46 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1195378
Environment:
Last Closed: 2015-05-14 17:29:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Raghavendra G 2015-02-24 10:24:29 UTC
+++ This bug was initially created as a clone of Bug #1195378 +++

Description of problem:

During performance testing I see the following messages spamming the client logs:

[2015-02-23 05:06:06.355467] W [dict.c:329:dict_set] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/cluster/distribute.so(dht_selfheal_layout_lock_cbk+0x10) [0x7fc76447b110] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/cluster/distribute.so(dht_refresh_layout+0x30e) [0x7fc76447b08e] (-->/usr/lib64/libglusterfs.so.0(dict_set_uint32+0x3b) [0x7fc76ef32ceb]))) 0-dict: !this || !value for key=trusted.glusterfs.dht
[2015-02-23 05:06:06.355478] W [MSGID: 109003] [dht-selfheal.c:270:dht_refresh_layout] 0-testvol-dht: /file_dstdir/192.168.52.107/thrd_07/d_008/d_009: Failed to set dictionary value:key = trusted.glusterfs.dht
[2015-02-23 05:06:06.356455] I [dict.c:371:dict_get] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/cluster/distribute.so(dht_inodelk_done+0x4e) [0x7fc7644702ce] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/cluster/distribute.so(dht_selfheal_layout_lock_cbk+0x10) [0x7fc76447b110] (-->/usr/lib64/glusterfs/3.6.0.46/xlator/cluster/distribute.so(dht_refresh_layout+0xb3) [0x7fc76447ae33]))) 0-dict: !this || key=trusted.glusterfs.dht

Version-Release number of selected component (if applicable):

glusterfs-3.6.0.46-1.el6.x86_64

How reproducible:

Every run.

Steps to Reproduce:
1.  Run gluster benchmark kit on 2x1 volume.
2.  Check logs

Actual results:

The mount logs are spammed with the above messages, also note that performance is poor.

Expected results:

Normal operation / performance.

Additional info:

Comment 1 Anand Avati 2015-02-24 11:10:19 UTC
REVIEW: http://review.gluster.org/9733 (cluster/dht: create request dictionary if necessary during refresh layout.) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 2 Anand Avati 2015-03-04 09:07:56 UTC
REVIEW: http://review.gluster.org/9733 (cluster/dht: create request dictionary if necessary during refresh layout.) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 3 Anand Avati 2015-03-05 08:57:00 UTC
REVIEW: http://review.gluster.org/9733 (cluster/dht: create request dictionary if necessary during refresh layout.) posted (#4) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 4 Anand Avati 2015-03-05 11:19:17 UTC
REVIEW: http://review.gluster.org/9733 (cluster/dht: create request dictionary if necessary during refresh layout.) posted (#5) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 5 Anand Avati 2015-03-05 15:00:58 UTC
REVIEW: http://review.gluster.org/9733 (cluster/dht: create request dictionary if necessary during refresh layout.) posted (#6) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 6 Anand Avati 2015-03-06 06:21:04 UTC
REVIEW: http://review.gluster.org/9733 (cluster/dht: create request dictionary if necessary during refresh layout.) posted (#7) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 7 Anand Avati 2015-03-06 08:55:57 UTC
REVIEW: http://review.gluster.org/9733 (cluster/dht: create request dictionary if necessary during refresh layout.) posted (#8) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 8 Anand Avati 2015-03-06 08:57:04 UTC
COMMIT: http://review.gluster.org/9733 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit c6bfde4da5da40f81ab7d96f4d43adb2553a633d
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Tue Feb 24 16:36:05 2015 +0530

    cluster/dht: create request dictionary if necessary during refresh
    layout.
    
    Change-Id: I5a5d793c86ee5de345608eede5618e4e6c02af9f
    BUG: 1195668
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/9733

Comment 9 Niels de Vos 2015-05-14 17:29:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 10 Niels de Vos 2015-05-14 17:35:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 11 Niels de Vos 2015-05-14 17:38:13 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 12 Niels de Vos 2015-05-14 17:46:00 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.