Bug 119570 - (IDE SOFTRAID)Fails to see ide drive - but sees sata
(IDE SOFTRAID)Fails to see ide drive - but sees sata
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-31 09:13 EST by Pete Bradbury
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:59:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Bradbury 2004-03-31 09:13:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
BTopenworld; .NET CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
Just downloaded the dvd version of fedora core 2 for x86-64

During the graphical and text boot in annoconda, the detection of my 
winxp sata raid is detected. 

However as I wish to install on a third drive, my ide drive the 
installation fails when I ask not to initialise sda or sdb. My ide 
drive is not recognised at this stage.

The install fails. 

Using the old fedora core 1 test - installs as expected

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run linux or linux text
2.setup language, monitor etc
3.arrive at custom partion or druid - both fail to ask for the ide 
drive
    

Actual Results:  System close down and reboots - repeats again ...

Expected Results:  I would have hope for the ide drive been 
recognised and used to install the linux system

Additional info:

The system:  ASUS sk8n - Athlon AMD 64 FX51, 1 gig ram, radeon 9800 
pro. Viewsonic vp211b,
Comment 1 Pete Bradbury 2004-03-31 11:37:41 EST
Just noticed that the hdc drive - ide - is not being recognised 
during the installation.

On linux mediacheck (which passed )the fedora 2 core is reported as 
Fedora 1.91 DVD

Also in anaconda the release notes are reported as missing

As the sata raid array seems to be screwing up the recognition of the 
ide device - should I disable it from the bios until Fedora 2 is 
installed - and later re-enable it through the bios - could this be a 
possible solution? Or is there a workaround?

My fedora core 1 (0.96 I think) installation recognises both sata and 
ide (although the raid isn't operable)
Comment 2 Pete Bradbury 2004-04-01 02:16:19 EST
Just disabled the promise sata raid array in the bios and tried a 
fresh attempt to install.

The custom install again fails when using the autopartitio and druid, 
with a device not found error, as though the ide drive does not 
exist, but without the dvd in place it boots straight into the old 
fedora core 1 test?
Comment 3 Jeremy Katz 2004-04-05 17:28:27 EDT
Can you grab both /tmp/syslog and /tmp/anaconda.log and put them on a
floppy using tty2 during the installation?
Comment 4 Pete Bradbury 2004-04-05 17:44:18 EDT
I changed my setup by departitioning the ide drive and the
installation worked. However a second install over the new fedora 2 failed
So I departitoned and it installed fine.
Comment 5 Jeremy Katz 2004-04-11 12:55:21 EDT
There's not kernel support for the (mostly software) IDE RAIDs.
Comment 6 Dave Jones 2005-02-24 01:01:19 EST
Alasdair, wasnt device-mapper supposed to be doing this ?
Comment 7 Dave Jones 2005-04-16 00:59:46 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.