Bug 119574 - halt initscript doesn't save mixer settings / ALSA
halt initscript doesn't save mixer settings / ALSA
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-31 09:38 EST by Michael Schwendt
Modified: 2014-03-16 22:43 EDT (History)
2 users (show)

See Also:
Fixed In Version: 7.49-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-31 23:40:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2004-03-31 09:38:33 EST
By default, ALSA drivers are "mute" after being loaded. If user starts
a mixer (e.g. alsamixer) to un-mute the audio channels and set the
mixers, these settings will not survive the next reboot and the
system's audio starts "mute" again.

Initscript "halt" contains the following lines for old OSS/Free audio
drivers, which save mixer settings on reboot/shutdown:

# Save mixer settings, here for lack of a better place.
grep -q "\(sparcaudio\|sound\)" /proc/devices
if [ $? = 0 -a -x /bin/aumix-minimal ]; then
   runcmd $"Saving mixer settings" /bin/aumix-minimal -f /etc/.aumixrc -S
fi

With ALSA, it should be similar, but done with "/usr/sbin/alsactl
store" (or amixer), which saves settings to /etc/asound.state. These
would be restored (via modprobe.conf) when the kernel modules are loaded.

Note that the following entry in /etc/modprobe.conf is not enough,
because reboot/shutdown does not unload kernel modules:

remove snd-ens1371 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-ens1371


Version-Release number of selected component (if applicable):
initscripts-7.48-1

How reproducible:
Always

Steps to Reproduce:
1. run alsamixer and change mixer settings
2. reboot
3. run alsamixer to verify mixer settings
    

Actual Results:  Mixer settings haven't survived the reboot.


Expected Results:  Mixer settings should have survived the reboot.


Additional info: Is "aumix" package still of use anywhere?
Comment 1 Karen Spearel 2004-03-31 11:28:48 EST
I did a clean i386 FC2 T2 install with SELinux disabled and later
installed xmms-mp3 from Livna.  I was pleasantly surprised that MP3s
played immediately without fiddling with alsamixer and the volume
control applet worked fine.  However, upon reboot, no volume and after
starting alsamixer, it shows PCM as muted with zero volume although
the  Master was not muted and volume level was per the volume control
applet.
This is with the NForce2/Realtek ALC650 Rev 2 all properly installed
during installation and with all initial modprobe.conf settings
unmodified.  I am not using surround sound but I note that in
alsamixer, Center came up at 100% but thankfully muted.  
Comment 2 Bill Nottingham 2004-03-31 23:40:21 EST
This is fixed in 7.49-1.

Note You need to log in before you can comment on or make changes to this bug.