Bug 1195784 - [RFE] Let the user change the name of an imported block Storage Domain
Summary: [RFE] Let the user change the name of an imported block Storage Domain
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Fred Rolland
QA Contact: Ori Gofen
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-24 14:56 UTC by Maor
Modified: 2016-03-09 20:58 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1222571 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:58:25 UTC
oVirt Team: Storage
Target Upstream Version:
sherold: Triaged+


Attachments (Terms of Use)
importExportStorageDomain (46.70 KB, image/png)
2015-03-01 09:55 UTC, Maor
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 41060 master MERGED webadmin: Enable editing name on import iscsi SD Never

Description Maor 2015-02-24 14:56:27 UTC
Description of problem:
We should add the possibility for the user redefine properties such as name, description and comment when importing a Storage Domain whether it is a Data Storage Domain or an Export Storage Domain.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Import an existing Storage domain with the same name which already exists in the setup
2.
3.

Actual results:
a CDA message will appear and the dialog does not have provide the user the ability to redefine those fields in the dialog

Expected results:
the dialog box should have fields such as Name and Description which the user can override or keep the default values as it is.


Additional info:

Comment 1 Maor 2015-02-24 15:08:05 UTC
We currently don't have this feature for re-define name, description and more.
Currently we can't import an Export Domain which have the same name as another Storage domain in the setup.

to fix this behavior we should think how do we want to show this in the dialog box when importing a Storage Domain.
for example, we can have a checkbox which will be checked only if the user does not want to use the defaults configured in the Storage Domain, and then one can redefine all the rest of the fields.

Comment 2 Tal Nisan 2015-02-25 09:19:59 UTC
Maor, can you attach images of the current dialog so it'll be easier for the ux guys to guide us?

Comment 3 Maor 2015-03-01 09:55:54 UTC
Created attachment 996738 [details]
importExportStorageDomain

Comment 5 Fred Rolland 2015-05-18 14:33:30 UTC
The fix provided is for block storage domain only:

For block storage domains, the name of the storage domain in the table
in the import domain window of will be now editable.
The user can change the name before importing the domain.

Note that the new name will not be updated in the storage domain
metadata unless the user will change the name when the storage
domain will be active.
It is the same behavior as in REST API.

This bug will be duplicated for NFS storage domain handling.

Comment 7 Max Kovgan 2015-06-28 14:13:01 UTC
ovirt-3.6.0-3 release

Comment 8 Kevin Alon Goldblatt 2015-07-15 05:42:28 UTC
Verified with Version:
-----------------------------------------
vdsm-4.17.0-1054.git562e711.el7.noarchrpm -qa 
ovirt-engine-3.6.0-0.0.master.20150627185750.git6f063c1.el6.noarch


Verified using the following scenario:
-----------------------------------------
Steps to reproduce:

1. Import data domain on different dc with the same name as and existing domain on the current system - an error is generated informing the user that the same domain name already exists
2. Click on the name of domain to be imported and change it to something else and press ok - the domain is imported with the new name.

Performed the following RFE test plan - test case 10883:
----------------------------------------


https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/wiki/Storage/3_5_Storage_ImportDomain_Between_DifferentSetups


Moving to VERIFIED!

Comment 11 Fred Rolland 2016-02-23 13:09:32 UTC
The doc text in [1] will cover also this defect.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1295852

Comment 13 errata-xmlrpc 2016-03-09 20:58:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.