Bug 1195796 - alternatives jre_1.8.0_exports and jre_openjdk_exports are dangling links
Summary: alternatives jre_1.8.0_exports and jre_openjdk_exports are dangling links
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.8.0-openjdk
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: jiri vanek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-24 15:26 UTC by Andrew J. Schorr
Modified: 2015-02-26 14:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-26 14:41:17 UTC
Type: Bug


Attachments (Terms of Use)

Description Andrew J. Schorr 2015-02-24 15:26:00 UTC
Description of problem: The java-1.8.0-openjdk-headless-1.8.0.31-3.b13.fc21.x86_64 creates some alternatives symlinks that do not exist.
In particular, these 2 links are dangling:

bash-4.3$ stat -L /etc/alternatives/jre_1.8.0_exports /etc/alternatives/jre_openjdk_exports 
stat: cannot stat ‘/etc/alternatives/jre_1.8.0_exports’: No such file or directory
stat: cannot stat ‘/etc/alternatives/jre_openjdk_exports’: No such file or directory


The logic is here in the scriptlet:

for X in openjdk 1.8.0 ; do
  alternatives \
    --install /usr/lib/jvm/jre-"$X" \
    jre_"$X" /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.31-3.b13.fc21.x86_64/jre 1800031 \
    --slave /usr/lib/jvm-exports/jre-"$X" \
    jre_"$X"_exports /usr/lib/jvm-exports/java-1.8.0-openjdk-1.8.0.31-3.b13.fc21.x86_64/jre
done



Version-Release number of selected component (if applicable):
java-1.8.0-openjdk-headless-1.8.0.31-3.b13.fc21.x86_64

How reproducible:
bash-4.3$ ls -l /etc/alternatives/jre_1.8.0_exports /etc/alternatives/jre_openjdk_exports 
lrwxrwxrwx 1 root root 70 Feb 21 09:28 /etc/alternatives/jre_1.8.0_exports -> /usr/lib/jvm-exports/java-1.8.0-openjdk-1.8.0.31-3.b13.fc21.x86_64/jre
lrwxrwxrwx 1 root root 70 Feb 21 09:28 /etc/alternatives/jre_openjdk_exports -> /usr/lib/jvm-exports/java-1.8.0-openjdk-1.8.0.31-3.b13.fc21.x86_64/jre
bash-4.3$ stat -L /etc/alternatives/jre_1.8.0_exports /etc/alternatives/jre_openjdk_exports 
stat: cannot stat ‘/etc/alternatives/jre_1.8.0_exports’: No such file or directory
stat: cannot stat ‘/etc/alternatives/jre_openjdk_exports’: No such file or directory


Steps to Reproduce:
1. stat -L /etc/alternatives/jre_1.8.0_exports /etc/alternatives/jre_openjdk_exports
2.
3.

Actual results: Symlinks in /etc/alternatives point to nonexistent paths.


Expected results: No dangling symlinks.


Additional info:

Comment 1 Andrew J. Schorr 2015-02-24 15:29:03 UTC
I guess this is similar to the problem in bug #1119100

Comment 2 jiri vanek 2015-02-25 11:03:34 UTC
Hello, this should be fixed in: https://admin.fedoraproject.org/updates/FEDORA-2015-2389/java-1.8.0-openjdk-1.8.0.31-5.b13.fc21
whhich contains http://pkgs.fedoraproject.org/cgit/java-1.8.0-openjdk.git/commit/?h=f21&id=e170d8662d94e20ba38c02340b91323565849f1f

The build is already in stable. If this update fix your issue, please close this bug as fixed.

Comment 3 Andrew J. Schorr 2015-02-26 14:41:17 UTC
The update fixed it.  Thanks.  For some reason, I cannot set the bug status to "FIXED".  I guess that option may be available only to maintainers.  I'm picking instead what seems to be the best choice available to me as a user -- CURRENTRELEASE.  But I don't think that's technically a correct usage.


Note You need to log in before you can comment on or make changes to this bug.