This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1195962 - Missing tool intel-virtual-output
Missing tool intel-virtual-output
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
21
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-24 17:14 EST by mail-redhat
Modified: 2015-09-02 12:44 EDT (History)
4 users (show)

See Also:
Fixed In Version: xorg-x11-drv-intel-2.99.917-6.20150211.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-02 05:55:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mail-redhat 2015-02-24 17:14:13 EST
Description of problem:
This is more a request than a bug report. I cannot get a specific setup running i915 as the primary card together with my nvidia card in an optimus setup without having the tool intel-virtual-output which is part of the package sources but not packaged.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.99.916-3.20141117.fc21.x86_64

How reproducible:
Install the given package


Steps to Reproduce:
n/a

Actual results:
There is no binary intel-virtual-output


Expected results:
intel-virtual-output should be build as part of the driver's tools


Additional info:
Comment 1 Fedora Update System 2015-02-28 05:27:23 EST
xorg-x11-drv-intel-2.99.917-6.20150211.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/xorg-x11-drv-intel-2.99.917-6.20150211.fc22
Comment 2 Fedora Update System 2015-02-28 11:42:03 EST
Package xorg-x11-drv-intel-2.99.917-6.20150211.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-intel-2.99.917-6.20150211.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2884/xorg-x11-drv-intel-2.99.917-6.20150211.fc22
then log in and leave karma (feedback).
Comment 3 mail-redhat 2015-03-03 07:44:45 EST
I want to notify you that there is still no package named like that as for now:

sudo yum update --enablerepo=updates-testing xorg-x11-drv-intel-2.99.917-6.20150211.fc22 1 ↵
Loaded plugins: langpacks
No Match for argument: xorg-x11-drv-intel-2.99.917-6.20150211.fc22
No package xorg-x11-drv-intel-2.99.917-6.20150211.fc22 available.
No packages marked for update
Comment 4 Fedora Update System 2015-03-09 04:33:29 EDT
xorg-x11-drv-intel-2.99.917-6.20150211.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Christoph Löhr 2015-08-28 12:07:37 EDT
It's missing again in  12.20150615.fc22
Comment 6 Hans de Goede 2015-09-02 05:55:51 EDT
Hi,

(In reply to Christoph Löhr from comment #5)
> It's missing again in  12.20150615.fc22

Do you have the intel-gpu-tools package installed ? intel-virtual-output is part of that package, rather then of the main drv package.

I just checked and it is right there where it should be in the latest f22 build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=679140

Regards,

Hans
Comment 7 mail-redhat 2015-09-02 12:44:29 EDT
That's a good hint. Thanks! intel-gpu-tools.x86_64 2.99.917-15.20150729.fc22 conflicts with xorg-x11-drv-intel-devel-2.99.917-12.20150615.fc22.x86_64 in files /usr/bin/intel-gen4asm and /usr/bin/intel-gen4disasm but since I don't actually need the devel package removing it before installing the gpu-tools fixes it for me.

Note You need to log in before you can comment on or make changes to this bug.