Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1195976 - [MetaData - Versions] Restoring an old version, doesn't change the Restore Button to Save
Summary: [MetaData - Versions] Restoring an old version, doesn't change the Restore Bu...
Keywords:
Status: CLOSED EOL
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ER5
: 6.2.0
Assignee: Walter Medvedeo
QA Contact: Lukáš Petrovický
Dawn Eisner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-24 22:42 UTC by Vikram Goyal
Modified: 2020-03-27 19:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-27 19:47:57 UTC
Type: Bug


Attachments (Terms of Use)

Description Vikram Goyal 2015-02-24 22:42:57 UTC
Testing in ER5 BPMS 6.1 on EAP.

I tried this with a dummy WorkItemDefinition.

I created several versions of my WID and then tried to restore an older version. The restore works properly, but the Restore button doesn't change back to "Save". It stays as "Restore".

Only if I close the WID screen and open it again does the "Save" button come back.

Comment 2 Walter Medvedeo 2015-03-03 11:08:23 UTC
fixed in master with the following commit

https://github.com/uberfire/uberfire-extensions/commit/2689e727ac8140a3851756bb619c3916abcd8034

Comment 4 Jiri Locker 2015-11-09 16:28:36 UTC
Fixed in ER5.


Note You need to log in before you can comment on or make changes to this bug.