Bug 119601 - firstboot cannot open screen :1 on firstboot
firstboot cannot open screen :1 on firstboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-31 15:29 EST by G.Wolfe Woodbury
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 11:34:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server log for firstboot run (36.13 KB, text/plain)
2004-03-31 15:31 EST, G.Wolfe Woodbury
no flags Details
Messages abstract from firstboot time of system (4.57 KB, text/plain)
2004-03-31 15:38 EST, G.Wolfe Woodbury
no flags Details
XFree86.1.log related to firstboot cannot open :1 (Apr 03,2004) (35.96 KB, text/plain)
2004-04-04 01:39 EST, G.Wolfe Woodbury
no flags Details
Xorg.1.log for install of FC2 final (35.08 KB, text/plain)
2004-07-01 17:29 EDT, G.Wolfe Woodbury
no flags Details

  None (edit)
Description G.Wolfe Woodbury 2004-03-31 15:29:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Firstboot attempts to run, but fails with a window manager error of
being unable to open :1.   There are no errors in the XFree86.1.log
and it looks like there are only some minor avc's involved.

Version-Release number of selected component (if applicable):
firstboot-1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1. install from development/rawhide
2. reboot as normal
3. watch firstboot fail
    

Actual Results:  firstboot fails to open the X-server started on vt02
claiming it can't open :1

Expected Results:  normal firstboot processing

Additional info:

Computer: AMD-K6-2 @ 333MHz    ATI Mach64 Video card   320MB RAM  etc.

Attached is XFree log.
Comment 1 G.Wolfe Woodbury 2004-03-31 15:31:55 EST
Created attachment 99017 [details]
X server log for firstboot run
Comment 2 G.Wolfe Woodbury 2004-03-31 15:38:47 EST
Created attachment 99018 [details]
Messages abstract from firstboot time of system
Comment 3 G.Wolfe Woodbury 2004-04-04 01:38:21 EST
Fresh development install from snapshot of Sat Apr 03,2004:

Still doesn't run firstboot correctly.  This version of anaconda seems
to be very confused about SELinux, according to the install, SEL is
"disabled" and there are lots of kernel: security_context_to_sid
messages (probably unrelated to this bug)

Attaching XFree86.1.log for viewing
Comment 4 G.Wolfe Woodbury 2004-04-04 01:39:44 EST
Created attachment 99095 [details]
XFree86.1.log related to firstboot cannot open :1 (Apr 03,2004)
Comment 5 G.Wolfe Woodbury 2004-04-19 02:07:05 EDT
as of 4/17/2004 the bug still occurs, BUT, if rhgb is allowed to run
it doesn't happen.  Should add that bug occurs when rhgb is NOT used.
Comment 6 Brent Fox 2004-04-20 15:20:46 EDT
I have not been able to reproduce this bug.  Can you provide more info
about how you disabed rhgb?
Comment 7 G.Wolfe Woodbury 2004-04-20 21:42:39 EDT
I simply didn't install it.  Unselect rhgb from the packages list
using "custom" install.
Comment 8 Brent Fox 2004-04-30 14:44:37 EDT
I wonder if this wasn't an SELinux bug.  I am unable to reproduce it
with test3.  Can you try with test3 and see if it still happens?
Comment 9 G.Wolfe Woodbury 2004-05-01 00:26:41 EDT
I just did a full install from rawhide/test3 and the error occurred.
There was the usual lack of errors in the X server log and a flash of
"RunTime Error: could not open screen :1" as firstboot failed.  I did
an install with "rhgb" in the mix, and firstboot works.  Installing
with rhgb excluded makes firstboot fail.

Additional possibility, the video card is and ATI Rage XL/Mach 64
older card.  Works well, but is a bit aged.

SELinux is not involved in this one.   If you want to come over to
Durham, I can show you the setup. :-)
Comment 10 G.Wolfe Woodbury 2004-05-04 19:32:06 EDT
Full install of FC2rawhide as of 2005.05.04 (May 4) without RHGB and
firstboot *succeeded* to run.  Seems the version of kernel and other
pieces let it work right on my hardware this time.

I'm going to close the bug.
Comment 11 G.Wolfe Woodbury 2004-05-10 00:37:47 EDT
FC2rawhide of 2005.05.09 *fails* to start firstboot correctly without
RHGB in the mix.   ReOpening bug.
Comment 12 david d zuhn 2004-05-19 14:34:38 EDT
I just installed FC2 (final), and disabled rhgb (by editing the kernel
line in grub on the first boot of the new system).  I watched the
system attempt to bring up the firstboot X server, which failed, and
then the regular X server fired up w/ GDM just fine.  

I switched to vt0 (1, whichever I get from C-A-1), ran firstboot
manually and that worked okay.

This is a Dell Latitude laptop, NM256AV video.  
Comment 13 Brent Fox 2004-06-25 11:54:30 EDT
Hmm, I'm just not able to reproduce this on my test machines.  

ggw: can you try again with FC2 final and see if you still have the
problem?
Comment 14 G.Wolfe Woodbury 2004-06-26 18:30:26 EDT
I did an FC2 install both with and without rhgb included.  If rhgb is
included, firstboot works fine; without rhgb it starts up the x server
on screen :1 and then fails with "Runtime error: cannot open display"

This is a 400MHz K6-2 with PCI ATI Rage XL (Mach 64 driver)

Installing from rawhide as of 2004-06-25 yeilds the same results.
Comment 15 Brent Fox 2004-07-01 10:21:28 EDT
Are there any xorg logs in /var/logs?  
Comment 16 G.Wolfe Woodbury 2004-07-01 17:29:13 EDT
Created attachment 101572 [details]
Xorg.1.log for install of FC2 final

this is the requested xorg.1.log
Comment 17 G.Wolfe Woodbury 2004-07-01 17:36:18 EDT
I understand you are having trouble reproducing this bug.  It seems to
be a problem with attaching the window manager to the :1 screen.  The
display comes up with a root X cursor, and moving it works; but very
quickly the server exits and firstboot reports its failure.

Selinux is NOT enabled, so it is not a problem with that.  There might
be a permission problem on the vt02 device, but since it is running in
root context that seems to be a non-cause.  The biggest hint to me is
that having rhgb in the mix allows firstboot to work;  there is
something not being properly initialized if rhgb isn't running.
Comment 18 G.Wolfe Woodbury 2004-07-18 08:07:06 EDT
A rawhide/development install of 2004-07-17 does NOT exhibit the problem!
Comment 19 G.Wolfe Woodbury 2004-07-24 00:17:20 EDT
Rawhide/Development/FC3t1 of 2004-07-23 still does NOT have this bug.
 Unless some kernel change re-introduces it, I'd say it been swatted.
Comment 20 Brent Fox 2004-07-26 10:38:15 EDT
Ok, closing as Rawhide.  Thanks for your help on this report.
Comment 21 G.Wolfe Woodbury 2004-08-07 08:04:49 EDT
Rawhide of 2004-08-06 re-introduced the problem
It's back!
Comment 22 G.Wolfe Woodbury 2004-08-19 17:46:22 EDT
rawhide (development) of 2004-08-18 still exhibits the problem,  same
no errors in xorg logs.  Installing RHGB is still the workaround.
Comment 23 G.Wolfe Woodbury 2004-09-11 00:42:15 EDT
Firstboot is now failing differently on development of 2004-09-10

RHGB runs, then firstboot starts, but hangs forever (10 hours is
forever to a computer!)  Running firstboot from root user login works
as a workaround.  There are no exceptions or error messages in the
logs for this failure.
Comment 24 Russell Coker 2004-09-22 13:29:08 EDT
I am seeing this error too.  It occurs on a fairly default 
workstation install of FC3T2.  It is not a SE Linux issue, it 
happens when booted with enforcing=0. 
 
I can provide administrative access to a machine that has this 
problem with serial console if it helps.  Contact me with my 
redhat.com email address if interested. 
Comment 25 G.Wolfe Woodbury 2004-09-28 11:36:30 EDT
Rawhide of 2004-09-27 shows the problem.
Comment 26 G.Wolfe Woodbury 2004-09-28 16:31:45 EDT
also happens on fresh install of rawhide of 2004-09-28
Comment 27 Barry K. Nathan 2004-09-28 16:58:07 EDT
Me too, with 2004-09-27 rawhide, albeit with different symptoms than
what's being reported here (so maybe I need a different bug, although
I don't know for sure): firstboot seems to quickly fail (I didn't time
it -- I was away from the computer for several minutes -- but it sure
wasn't 10 hours) and the only evidence I see is:

a) "firstboot:  failed" in /var/log/messages
b) /etc/sysconfig/firstboot is missing
Comment 28 G.Wolfe Woodbury 2004-10-01 18:50:34 EDT
fresh install of rawhide 2004-10-01 fails.  Exact same symptoms.
Comment 29 G.Wolfe Woodbury 2004-10-16 01:08:53 EDT
rawhide install of 2004-10-15 has the problem.  If RHGB is not
installed firstboot will not properly open the display for running...
If RHGB *is* installed it works okay.
Comment 30 G.Wolfe Woodbury 2005-01-10 17:40:25 EST
rawhide fresh install from 2005.01.09 does NOT exhibit the problem. 
Installing without RHGB and firstboot did run fine.
Comment 31 Chris Lumens 2005-07-11 16:31:37 EDT
Please test with FC4 and report if it's still off-and-on broken or not.
Comment 32 G.Wolfe Woodbury 2005-09-16 20:20:57 EDT
Seems to be working with rawhide 2005-09-13, FC5.  Also the FC4 final worked fine.

Note You need to log in before you can comment on or make changes to this bug.