Bug 1196050 - perl-Params-Validate-1.18 testsuite failure on f20
Summary: perl-Params-Validate-1.18 testsuite failure on f20
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Params-Validate
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ralf Corsepius
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-25 08:15 UTC by Ralf Corsepius
Modified: 2015-03-21 04:58 UTC (History)
5 users (show)

Fixed In Version: perl-Params-Validate-1.18-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-21 04:58:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Ralf Corsepius 2015-02-25 08:15:18 UTC
Description of problem:

perl-Params-Validate-1.18's testsuite fails with a weird error on f20:

...
t/release-pp-35-default-xs-bug.t ........ ok
t/release-pp-36-large-arrays.t .......... ok
t/release-pp-37-exports.t ............... ok
t/release-pp-38-callback-message.t ...... ok
t/release-pp-is-loaded.t ................ ok
Subroutine foo redefined at lib/Params/Validate.pm line 83.
Subroutine bar redefined at lib/Params/Validate.pm line 93.
Subroutine foo2 redefined at lib/Params/Validate.pm line 98.
t/release-synopsis.t .................... ok
#   Failed test 'check version in 'blib/lib/Params/ValidatePP.pm''
#   at t/release-test-version.t line 29.
# No version was found in 'blib/lib/Params/ValidatePP.pm'.
#   Failed test 'check version in 'blib/lib/Params/ValidateXS.pm''
#   at t/release-test-version.t line 29.
# No version was found in 'blib/lib/Params/ValidateXS.pm'.
# Looks like you failed 2 tests of 8.
t/release-test-version.t ................ 
Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/8 subtests 
t/release-xs-is-loaded.t ................ ok
t/release-xs-segfault.t ................. ok
Test Summary Report
-------------------
t/34-recursive-validation.t           (Wstat: 0 Tests: 1 Failed: 0)
  TODO passed:   1
t/release-test-version.t              (Wstat: 512 Tests: 8 Failed: 2)
  Failed tests:  3-4
  Non-zero exit status: 2
Files=91, Tests=1112,  5 wallclock secs ( 0.32 usr  0.06 sys +  5.29 cusr  0.40 csys =  6.07 CPU)
Result: FAIL
Failed 1/91 test programs. 2/1112 subtests failed.
Version-Release number of selected component (if applicable):


How reproducible:
Always.

Additional info:
- This failure does not occur on fedora > 20, which lets me assume the cause to be in an implicit/indirect package dep or in perl itself.

Comment 1 Ralf Corsepius 2015-02-25 08:26:20 UTC
Reported upstream:
CPAN: https://rt.cpan.org/Public/Bug/Display.html?id=102343

Comment 2 Paul Howarth 2015-02-25 09:20:00 UTC
Looks like you're hitting this:

https://github.com/xenoterracide/Test-Version/issues/4

I could update perl-Test-Version to ≥ 1.003001 in F-20, which will probably fix this, or you could skip the release tests there.

Comment 3 Ralf Corsepius 2015-02-25 09:44:35 UTC
(In reply to Paul Howarth from comment #2)
> I could update perl-Test-Version to ≥ 1.003001 in F-20, which will probably
> fix this
I already tried this, but no success so far.

Actually, I already rebuilt (from f21):

perl-Carp-1.33.01-2.fc20.noarch.rpm
perl-ExtUtils-MakeMaker-6.98-2.fc20.noarch.rpm
perl-File-Temp-0.23.04-2.fc20.noarch.rpm
perl-Module-Build-0.42.06-2.fc20.noarch.rpm
perl-PathTools-3.47-3.fc20.x86_64.rpm
perl-Scalar-List-Utils-1.41-1.fc20.x86_64.rpm
perl-Test-Requires-0.08-1.fc20.noarch.rpm
perl-Test-Simple-1.001008-1.fc20.noarch.rpm
perl-Test-Version-1.004001-1.fc20.noarch.rpm
perl-version-0.99.12-1.fc20.x86_64.rpm

> or you could skip the release tests there.
Yep, this would be the last resort. The other alternative would be to not upgrade perl-Params-Validate for f20.

Comment 4 Paul Howarth 2015-02-25 10:19:21 UTC
It also needs a perl-Module-Metadata update; F-20 has 1.000019.

https://rt.cpan.org/Public/Bug/Display.html?id=84357

I tried 1.000026 along with Test-Version 1.004001 and that worked.

Comment 5 Ralf Corsepius 2015-02-25 10:50:55 UTC
(In reply to Paul Howarth from comment #4)
> It also needs a perl-Module-Metadata update; F-20 has 1.000019.
> 
> https://rt.cpan.org/Public/Bug/Display.html?id=84357
> 
> I tried 1.000026 along with Test-Version 1.004001 and that worked.

Excellent! This also works for me. 

AFAIS, you're maintaining both perl-Module-Metadata and perl-Test-Version, so could you please push an update of these for f20?

Comment 6 Paul Howarth 2015-02-25 12:34:39 UTC
Updates built and submitted, along with buildroot overrides, which are now in the F-20 buildroot so you should be able to build in koji now.

Comment 7 Fedora Update System 2015-03-10 04:44:05 UTC
perl-Params-Validate-1.18-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/perl-Params-Validate-1.18-1.fc20

Comment 8 Fedora Update System 2015-03-12 16:32:11 UTC
Package perl-Params-Validate-1.18-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Params-Validate-1.18-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-3567/perl-Params-Validate-1.18-1.fc20
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-03-21 04:58:25 UTC
perl-Params-Validate-1.18-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.