Bug 1196090 - FTBFS: IQmol fails to build with gfortran-5.0 (undefined references to _gfortran_os_error)
Summary: FTBFS: IQmol fails to build with gfortran-5.0 (undefined references to _gfort...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: IQmol
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Susi Lehtola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-25 09:48 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2015-02-26 01:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-26 01:57:26 UTC


Attachments (Terms of Use)
patch to fix build with gfortran-5.0 (2.51 KB, application/mbox)
2015-02-25 09:48 UTC, Dominik 'Rathann' Mierzejewski
no flags Details

Description Dominik 'Rathann' Mierzejewski 2015-02-25 09:48:28 UTC
Created attachment 995065 [details]
patch to fix build with gfortran-5.0

Description of problem:
IQmol fails to link due to undefined references to gfortran symbols.

Version-Release number of selected component (if applicable):
2.3.0-3.fc23

How reproducible:
Always.

Steps to Reproduce:
1. Try building current git master

Actual results:
[...]
CMakeFiles/IQmol.dir/IQmol/symmol.f90.o: In function `s_coor_':
/builddir/build/BUILD/IQmol-df94cf68b9d9d813e4d781c7edb9ac638724dadf/src/IQmol/symmol.f90:1722: undefined reference to `
_gfortran_os_error'

Expected results:
Links successfully.

Additional info:
Patch to fix attached.

Comment 1 Susi Lehtola 2015-02-26 01:57:26 UTC
Thanks, imported.


Note You need to log in before you can comment on or make changes to this bug.