Bug 119611 - ALSA x86_64 breaks ogg123, gaim, etc.
ALSA x86_64 breaks ogg123, gaim, etc.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
: 123537 (view as bug list)
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-03-31 16:35 EST by Alessandro Polverini
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-28 05:53:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alessandro Polverini 2004-03-31 16:35:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040124 Galeon/1.3.14

Description of problem:
When trying to play an ogg file with ogg123 (I tested with the ogg
files coming with kde 3.2), I get the following error:
Floating Point Exception

And the player is useless.

Thanks,
Alex

Version-Release number of selected component (if applicable):
The one shipped with FC2-test2

How reproducible:
Always

Steps to Reproduce:
1. Install FC2 Test2
2. Configure correctly alsa drivers
3. Try to play the ogg files coming with kde3.2 (kopete ones, if I
remember correctly)
    

Additional info:
Comment 1 Justin M. Forbes 2004-04-15 23:29:14 EDT
Backtrace:
#0  0x0000003a63742b30 in snd_pcm_sw_params () from
/usr/lib64/libasound.so.2
#1  0x0000002a97ee5efa in ao_plugin_device_clear ()
   from /usr/lib64/ao/plugins-2/libalsa09.so
#2  0x0000002a97ee5936 in ao_plugin_open () from
/usr/lib64/ao/plugins-2/libalsa09.so
#3  0x0000003a5ee02142 in ?? () from /usr/lib64/libao.so.2
#4  0x00000000004058d5 in audio_reopen_action (buf=0x0, arg=0x4000) at
callbacks.c:60
#5  0x0000000000404a25 in execute_actions (buf=0x2a980e9010,
action_list=0x2a980e9100,
    position=0) at buffer.c:151
#6  0x0000000000404ba7 in buffer_thread_func (arg=0x0) at buffer.c:233
#7  0x0000003a5da056ab in start_thread () from /lib64/tls/libpthread.so.0
#8  0x0000003a5cfbab03 in thread_start () from /lib64/tls/libc.so.6
#9  0x0000000000000000 in ?? ()
Comment 2 Alessandro Polverini 2004-04-28 07:32:41 EDT
The same problem applies to FC2 test3
Comment 3 Colin Walters 2004-05-17 17:36:30 EDT
Can you try upgrading to the alsa-lib from here?

http://people.redhat.com/~walters/alsa/
Comment 4 Justin M. Forbes 2004-05-19 10:20:07 EDT
upgraded alsa-lib does not seem to fix the issue.  Of note, this also
seems to impact gaim, leaving a core every time it trys to play a sound.
Comment 5 Justin M. Forbes 2004-05-20 13:17:43 EDT
*** Bug 123537 has been marked as a duplicate of this bug. ***
Comment 6 Alessandro Polverini 2004-05-20 13:35:36 EDT
I too, have upgraded alsa-lib, but the program still gives the same error
Comment 7 Brown, Zach 2004-09-14 00:45:34 EDT
Well, the bug is clear, but I have no idea which passage in the twisty
ALSA/ao maze is to blame:

Program received signal SIGFPE, Arithmetic exception.
[Switching to Thread 1084225888 (LWP 22793)]
0x0000002a95599a70 in snd_pcm_sw_params (pcm=0x672160, params=0x409ff630)
    at pcm.c:822
822             if (params->start_threshold <= pcm->buffer_size &&

(gdb) list
817      */
818     int snd_pcm_sw_params(snd_pcm_t *pcm, snd_pcm_sw_params_t *params)
819     {
820             int err;
821             assert(pcm->setup);             /* the hw_params must
be set at first!!! */
822             if (params->start_threshold <= pcm->buffer_size &&
823                 params->start_threshold > (pcm->buffer_size /
params->avail_min) * params->avail_min) {
824                     SNDERR("snd_pcm_sw_params: params->avail_min
problem for start_threshold");
825                     return -EINVAL;
826             }

(gdb) print params->avail_min
$1 = 0

I worked around this by taking a stiff drink and then asking the
Multimedia Systems Selector to output to the OSS device.

- z
(heya, bill!)
Comment 8 Martin Stransky 2005-01-04 08:17:36 EST
Alsa-lib 1.0.7 has fix for this issue (see snd_pcm_sw_params). As soon
as alsa-drivers 1.0.7 comes to kernel, I'll upgrade Alsa-lib to 1.0.7

Note You need to log in before you can comment on or make changes to this bug.