Bug 1196182 - Unavailable repo metadata rhel-7-server-eus-rpms for RHEL 7.0
Summary: Unavailable repo metadata rhel-7-server-eus-rpms for RHEL 7.0
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng
Version: 7.0
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Lubos Kocman
QA Contact: Release Test Team
URL:
Whiteboard:
: 1194791 (view as bug list)
Depends On:
Blocks: 1203710
TreeView+ depends on / blocked
 
Reported: 2015-02-25 12:47 UTC by Fabrizio Pezzella
Modified: 2019-07-11 08:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-15 14:16:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1191933 1 None None None 2021-01-20 06:05:38 UTC

Internal Links: 1191933

Description Fabrizio Pezzella 2015-02-25 12:47:41 UTC
Unavailable repo metadata rhel-7-server-eus-rpms for RHEL 7.0 Server 

repo: rhel-7-server-eus-rpms

yum update
Loaded plugins: product-id, subscription-manager
https://cdn.redhat.com/content/eus/rhel/server/7/7Server/x86_64/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.

/etc/yum.repos.d/redhat.repo
[rhel-7-server-eus-rpms]
metadata_expire = 86400
sslclientcert = /etc/pki/entitlement/7567026201162808370.pem
baseurl = https://cdn.redhat.com/content/eus/rhel/server/7/$releasever/$basearch/os
ui_repoid_vars = releasever basearch
sslverify = 1
name = Red Hat Enterprise Linux 7 Server - Extended Update Support (RPMs)
sslclientkey = /etc/pki/entitlement/7567026201162808370-key.pem
gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
enabled = 1
sslcacert = /etc/rhsm/ca/redhat-uep.pem
gpgcheck = 1

Comment 1 Dennis Gregorovic 2015-02-25 14:41:18 UTC
Hi.  There's a bit of confusion here.  There was no EUS for RHEL 7.0.  EUS is being added to RHEL 7 for the first time with the 7.1 release.  As part of the preparation for 7.1, we have create the EUS content sets, which is why those yum repo definitions are starting to appear.  I've gone ahead and created empty repos.  This will avoid the 404 errors in yum.  Then, when 7.1 is releases, those EUS repos will get populated with the 7.1 content.

Comment 2 Fabrizio Pezzella 2015-02-25 14:48:26 UTC
Thanks Dennis for your quick reply.

I found this issue when I try to build docker image from official rhel-7 image

[root@rhel7-kub-master ~]# docker run -ti rhel7 yum repolist
Loaded plugins: product-id, subscription-manager
https://cdn.redhat.com/content/eus/rhel/server/7/7Server/x86_64/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
https://cdn.redhat.com/content/eus/rhel/server/7/7Server/x86_64/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.

Cheers,
Fabrizio

Comment 4 Valentina Mukhamedzhanova 2015-03-17 11:34:54 UTC
*** Bug 1194791 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.