Bug 1196198 - cobbler.cexceptions.CX: internal error, unknown profile name
Summary: cobbler.cexceptions.CX: internal error, unknown profile name
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 570
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Herr
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: sat570-triage
TreeView+ depends on / blocked
 
Reported: 2015-02-25 13:11 UTC by Pavel Studeník
Modified: 2015-04-30 20:02 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-30 20:02:07 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Pavel Studeník 2015-02-25 13:11:02 UTC
Description of problem:
I get traceback from cobbler during scheduling system. I deleted the profile and then tried to schedule new system with other profile.

>>> email <<<

Taskomatic bunch cobbler-sync-bunch was scheduled to run within the cobbler-sync-default schedule.

Subtask cobbler-sync failed.

For more information check /var/log/rhn/tasko/sat/cobbler-sync-bunch/cobbler-sync_306717_err.


Version-Release number of selected component (if applicable):
cobbler-2.0.7-52.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. create a kickstart profile
2. schedule a system
3. delete this kickstart profile
4. create new kickstart profile
5. during scheduling new system, I get traceback

Actual results:
with traceback

Expected results:
without traceback

Additional info:

>>> /var/log/rhn/tasko/sat/cobbler-sync-bunch/cobbler-sync_306717_err <<<
2015-02-25 07:47:11,843 [DefaultQuartzScheduler_Worker-1] ERROR com.redhat.rhn.taskomatic.task.CobblerSyncTask  - RuntimeExceptionError trying to sync to cobbler: redstone.xmlrpc.XmlRpcFault: <class 'cobbler.cexceptions.CX'>:'internal error, unknown profile name kvm-qemu-auto-wed25feb2015_07_10_42_18511:1:RedHatSatTeamQA'
java.lang.RuntimeException: redstone.xmlrpc.XmlRpcFault: <class 'cobbler.cexceptions.CX'>:'internal error, unknown profile name kvm-qemu-auto-wed25feb2015_07_10_42_18511:1:RedHatSatTeamQA'
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerCommand.invokeXMLRPC(CobblerCommand.java:104)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerCommand.invokeXMLRPC(CobblerCommand.java:115)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerProfileSyncCommand.syncProfileToSpacewalk(CobblerProfileSyncCommand.java:150)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerProfileSyncCommand.store(CobblerProfileSyncCommand.java:107)
	at com.redhat.rhn.taskomatic.task.CobblerSyncTask.execute(CobblerSyncTask.java:123)
	at com.redhat.rhn.taskomatic.task.RhnJavaJob.execute(RhnJavaJob.java:89)
	at com.redhat.rhn.taskomatic.TaskoJob.execute(TaskoJob.java:169)
	at org.quartz.core.JobRunShell.run(JobRunShell.java:216)
	at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:549)
Caused by: redstone.xmlrpc.XmlRpcFault: <class 'cobbler.cexceptions.CX'>:'internal error, unknown profile name kvm-qemu-auto-wed25feb2015_07_10_42_18511:1:RedHatSatTeamQA'
	at redstone.xmlrpc.XmlRpcClient.handleResponse(XmlRpcClient.java:443)
	at redstone.xmlrpc.XmlRpcClient.endCall(XmlRpcClient.java:376)
	at redstone.xmlrpc.XmlRpcClient.invoke(XmlRpcClient.java:165)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.invokeMethod(CobblerXMLRPCHelper.java:69)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerCommand.invokeXMLRPC(CobblerCommand.java:100)
	... 8 more
2015-02-25 07:47:11,843 [DefaultQuartzScheduler_Worker-1] ERROR com.redhat.rhn.taskomatic.task.CobblerSyncTask  - re-throwing exception since we havent yet.
2015-02-25 07:47:11,844 [DefaultQuartzScheduler_Worker-1] ERROR com.redhat.rhn.taskomatic.task.CobblerSyncTask  - Executing a task threw an exception: java.lang.RuntimeException
2015-02-25 07:47:11,844 [DefaultQuartzScheduler_Worker-1] ERROR com.redhat.rhn.taskomatic.task.CobblerSyncTask  - Message: redstone.xmlrpc.XmlRpcFault: <class 'cobbler.cexceptions.CX'>:'internal error, unknown profile name kvm-qemu-auto-wed25feb2015_07_10_42_18511:1:RedHatSatTeamQA'
2015-02-25 07:47:11,844 [DefaultQuartzScheduler_Worker-1] ERROR com.redhat.rhn.taskomatic.task.CobblerSyncTask  - Cause: redstone.xmlrpc.XmlRpcFault: <class 'cobbler.cexceptions.CX'>:'internal error, unknown profile name kvm-qemu-auto-wed25feb2015_07_10_42_18511:1:RedHatSatTeamQA'
2015-02-25 07:47:11,844 [DefaultQuartzScheduler_Worker-1] ERROR com.redhat.rhn.taskomatic.task.CobblerSyncTask  - Stack trace:java.lang.RuntimeException: redstone.xmlrpc.XmlRpcFault: <class 'cobbler.cexceptions.CX'>:'internal error, unknown profile name kvm-qemu-auto-wed25feb2015_07_10_42_18511:1:RedHatSatTeamQA'
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerCommand.invokeXMLRPC(CobblerCommand.java:104)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerCommand.invokeXMLRPC(CobblerCommand.java:115)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerProfileSyncCommand.syncProfileToSpacewalk(CobblerProfileSyncCommand.java:150)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerProfileSyncCommand.store(CobblerProfileSyncCommand.java:107)
	at com.redhat.rhn.taskomatic.task.CobblerSyncTask.execute(CobblerSyncTask.java:123)
	at com.redhat.rhn.taskomatic.task.RhnJavaJob.execute(RhnJavaJob.java:89)
	at com.redhat.rhn.taskomatic.TaskoJob.execute(TaskoJob.java:169)
	at org.quartz.core.JobRunShell.run(JobRunShell.java:216)
	at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:549)
Caused by: redstone.xmlrpc.XmlRpcFault: <class 'cobbler.cexceptions.CX'>:'internal error, unknown profile name kvm-qemu-auto-wed25feb2015_07_10_42_18511:1:RedHatSatTeamQA'
	at redstone.xmlrpc.XmlRpcClient.handleResponse(XmlRpcClient.java:443)
	at redstone.xmlrpc.XmlRpcClient.endCall(XmlRpcClient.java:376)
	at redstone.xmlrpc.XmlRpcClient.invoke(XmlRpcClient.java:165)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.invokeMethod(CobblerXMLRPCHelper.java:69)
	at com.redhat.rhn.manager.kickstart.cobbler.CobblerCommand.invokeXMLRPC(CobblerCommand.java:100)
	... 8 more

Comment 9 Stephen Herr 2015-04-30 20:02:07 UTC
Closing NotABug as per comment 6.


Note You need to log in before you can comment on or make changes to this bug.