Bug 1196203 - 'tuskar role-list' outputs several blank lines
Summary: 'tuskar role-list' outputs several blank lines
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tuskarclient
Version: 6.0 (Juno)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ga
: Director
Assignee: Lennart Regebro
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
: 1234379 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-25 13:26 UTC by Udi
Modified: 2016-04-18 06:49 UTC (History)
8 users (show)

Fixed In Version: python-tuskarclient-0.1.18-3.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:50:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 187548 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Udi 2015-02-25 13:26:40 UTC
Description of problem:
When running 'tuskar role-list', some lines in the table are blank. You can even see it in the guide in https://openstack.redhat.com/TripleO-CLI where the role 'compute' is preceded by a blank line and followed by another blank line.


How reproducible:
100% 


Steps to Reproduce:
1. Follow the guide in https://openstack.redhat.com/TripleO-CLI


Actual results:

$ tuskar role-list
+--------------------------------------+----------------
| uuid                                 | name           
+--------------------------------------+----------------
| 5212f04b-ef84-47cb-ad47-608069586370 | cinder-storage 
| 648288aa-fa0f-422a-84d0-79fdadb1ab6d | compute        
|                                      |                
| 82114df3-e57d-4f3d-bd97-3fdcea83d76b | swift-storage  
| aa7b76ee-72e4-4f7b-b5b9-429cf20b5a7a | controller     
|                                      |                
+--------------------------------------+----------------

Comment 3 Lennart Regebro 2015-06-02 12:25:07 UTC
This is because descriptions can have newlines in them, and if the description ends with a newline, a blank line appears.

This patch attempts to fix this:

https://review.openstack.org/#/c/187548/

Comment 5 Udi 2015-06-10 06:12:42 UTC
In which version is it fixed? Can you please fill in the field "Fixed In Version" above? Thanks.

Comment 6 Lennart Regebro 2015-06-10 11:37:48 UTC
It's not yet released.

Comment 7 Lennart Regebro 2015-06-10 11:51:57 UTC
OK, apparently the state descriptions should be ignored.

Comment 8 Lennart Regebro 2015-06-22 10:52:58 UTC
This patch is now merged.

Comment 9 Ana Krivokapic 2015-06-22 13:35:00 UTC
*** Bug 1234379 has been marked as a duplicate of this bug. ***

Comment 13 Udi 2015-06-28 10:46:23 UTC
Verified in:
python-tuskarclient-0.1.18-3.el7ost.noarch
openstack-tuskar-0.4.18-3.el7ost.noarch

Comment 15 errata-xmlrpc 2015-08-05 13:50:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.