Bug 1196217 - Global "ErrorPolicy" option does not get validate by cups
Summary: Global "ErrorPolicy" option does not get validate by cups
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cups
Version: 6.7
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-25 14:05 UTC by Rupesh Patel
Modified: 2015-07-22 06:55 UTC (History)
1 user (show)

Fixed In Version: cups-1.4.2-70.el6
Doc Type: Bug Fix
Doc Text:
The ErrorPolicy configuration directive was not validated on startup, and an unintended default error policy could be used without a warning. The directive is now validated on startup and reset to the default if the configured value is incorrect. The intended policy is used, or a warning message is logged.
Clone Of:
: 1196218 (view as bug list)
Environment:
Last Closed: 2015-07-22 06:55:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1346 normal SHIPPED_LIVE cups bug fix and enhancement update 2015-07-20 17:59:51 UTC
CUPS Bugs and Features 4591 None None None Never

Description Rupesh Patel 2015-02-25 14:05:10 UTC
Version - cups-1.4* and above 

If i modify any of the option in cups.conf  and make spell mistake, it complains in error_log. However, this doesn't seems to validating option "ErrorPolicy" we added sometime back (default releases in RH-6 and after 1.3.7 rebase in RH-5)

Steps to reproduce this... 

1)
[root@dhcp233-34 ~]# grep Max /etc/cups/cupsd.conf
MaxLogSize   <---------- Remove size
[root@dhcp233-34 ~]#

[root@dhcp233-34 ~]# /etc/init.d/cups restart
Stopping cups:                                             [  OK  ]
Starting cups:
[root@dhcp233-34 ~]#                                        [  OK  ]
[root@dhcp233-34 ~]# cat /var/log/cups/error_log
E [25/Feb/2015:18:10:59 +0530] Missing integer value for MaxLogSize on line 1! <------ Complains integer missing

2)

[root@dhcp233-34 ~]# grep LogLevel  /etc/cups/cupsd.conf
LogLevel rn <------- made spell mistake in LogLevel
[root@dhcp233-34 ~]#

[root@dhcp233-34 ~]# cat /var/log/cups/error_log
E [25/Feb/2015:18:10:59 +0530] Missing integer value for MaxLogSize on line 1!
W [25/Feb/2015:18:11:57 +0530] Unknown LogLevel rn on line 11. <---------------  Complain for unknown level
[root@dhcp233-34 ~]#

[root@dhcp233-34 ~]# grep Error  /etc/cups/cupsd.conf
ErrorPolicy test@redhat.com <----------Error policy is invalid but it doesn't complain anything.
[root@dhcp233-34 ~]#

[root@dhcp233-34 ~]# cat /var/log/cups/error_log
E [25/Feb/2015:18:10:59 +0530] Missing integer value for MaxLogSize on line 1!
W [25/Feb/2015:18:11:57 +0530] Unknown LogLevel rn on line 11.
[root@dhcp233-34 ~]#

 ^^ no such commented by cups in error_log for invalid entry.

Comment 4 errata-xmlrpc 2015-07-22 06:55:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1346.html


Note You need to log in before you can comment on or make changes to this bug.