Bug 119631 - New kernel cant boot: VFS: no init found
New kernel cant boot: VFS: no init found
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-03-31 17:26 EST by thewade
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-04-01 11:28:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description thewade 2004-03-31 17:26:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b)

Description of problem:
I built a new kernel from kernel.org (2.6.3) and everything went
smoothly. Even Reboot. I then built 2.6.4 and again build went
smoothly, but now I cannot boot 2.6.4.
RAMDISK: compressed image found at block 0
RAMDISK: incomplete write (-1 != 32768) 4194304
VFS: Cannot open root device "LABEL=/" or unknown-block(0,0)
So I rebuilt 2.6.3 to use the new options I want, but that wont boot
eather for the same reason. kernel-2.6.1-1.65, the kernel that comes
with FC2t1 boots fine, except kudzu thinks my ethernet device is
removed, but still brings up eth0.
Dell Inspiron 8000
kernel-2.6.4 from kernel.org
Fedore Core 2 Test 1
Bug 2397 at bugzilla.kernel.org (I dont know if its the kernel, or the
build environment...)

Version-Release number of selected component (if applicable):
kernel-2.6.4 base kernel: kernel.org

How reproducible:

Steps to Reproduce:
1. Build new kernel
2. Reboot
3. Become depressed

Actual Results:  RAMDISK: compressed image found at block 0
RAMDISK: incomplete write (-1 != 32768) 4194304
VFS: Cannot open root device "LABEL=/" or unknown-block(0,0)
Wen grub.conf is modified to make root=/dev/hda1 instead of
root=LABEL=/ then the VFS line changes:
VFS: Cannot open initial console, try passing "init="
(or something to that effect)

Expected Results:  I should just boot up with the new kernel of course...

Additional info:
Comment 1 Sahil Verma 2004-03-31 18:59:45 EST

You've probably left out initrd in the kernel config (or ext2). Do a
'make defconfig' to get sane defaults, and take it from there.

Besides, this is the bugzilla for RedHat kernels only.

Comment 2 thewade 2004-03-31 19:09:53 EST
I read : http://seclists.org/lists/linux-kernel/2004/Jan/2748.html
And enabled both ramdisk and initrd, Hence the :
RAMDISK: compressed image found at block 0
RAMDISK: incomplete write (-1 != 32768) 4194304
But that didnt help.

As for the 'RedHat kernels only' Bugzilla sugguestion, I appologize if
this is a non-redhat kernel and thusly shouldnt be posted as a bug
here, I just didnt know if this is a build environment problem (Fedora
Core problem) or a kernel source problem (kernel.org problem). I have
bug postings in both places, and have not heard back from the
kernel.org bugzilla staff yet.

I will try the sane defaults to see what that gives me. Perhaps its
something else...
Thanks for the help!
Comment 3 thewade 2004-03-31 21:26:10 EST
i tried:
make clean
make defconfig
make xconfig
and ramdisk and initrd were not set, so I set them, among other
settings, and continued to:
sudo make install
WARNING: /lib/modules/2.6.4/kernel/lib/crc32.ko needs unknown symbol
WARNING: /lib/modules/2.6.4/kernel/lib/apm.ko needs unknown symbol
WARNING: /lib/modules/2.6.4/kernel/lib/apm.ko needs unknown symbol

Does the kernel now work, you ask?
No, same problem as before

I have posted my .config file to:
Comment 4 thewade 2004-04-01 11:28:35 EST
I emailed Linus Torvalds Himself! He says that I didnt need initrd or
ramdisk, but that root=LABEL=/ is a redhat (and thusly Fedora Core)
specific command, and the standard kernel doesnt support it. I ran df
and found that my root partotion is /dev/hda3, not /dev/hda1 which is
the kernel partition and would of course not have /dev or /initrd on it.

Change root=LABEL=/ to root=/dev/hdaX where X is your root parition
number, in /etc/grub.conf.

Nobody suguested to me to use df, and being a newbie...
THanks for your time.
Comment 5 Arjan van de Ven 2004-04-01 11:40:30 EST
Linus is somewhat wrong in that root=LABEL=/ is NOT a kernel thing;
it's 100% a userspace (initrd) thing, independent of the actual kernel
you're using....

Note You need to log in before you can comment on or make changes to this bug.