Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1196329 - Login fails for IE11/Server2008, unless compatibility-mode ON - rest of UI fails unless CM OFF
Summary: Login fails for IE11/Server2008, unless compatibility-mode ON - rest of UI fa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 570
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Grant Gainey
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
Depends On:
Blocks: sat570-triage
TreeView+ depends on / blocked
 
Reported: 2015-02-25 17:27 UTC by Julio Entrena Perez
Modified: 2019-06-13 08:16 UTC (History)
3 users (show)

Fixed In Version: spacewalk-java-2.3.8-101-sat spacewalk-web-2.3.2-32-sat
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-24 12:54:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
Internet Explorer 8 without compability mode (70.12 KB, image/png)
2015-02-25 17:27 UTC, Julio Entrena Perez
no flags Details
Internet Explorer 8 with compability mode (67.30 KB, image/png)
2015-02-25 17:28 UTC, Julio Entrena Perez
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1360823 0 None None None Never
Red Hat Product Errata RHBA-2015:0887 0 normal SHIPPED_LIVE Satellite 5.7 bug fix update 2015-04-24 16:54:30 UTC

Description Julio Entrena Perez 2015-02-25 17:27:15 UTC
Created attachment 995276 [details]
Internet Explorer 8 without compability mode

Description of problem:
Satellite 5.7 web interface is not rendered properly in Internet Explorer.

Version-Release number of selected component (if applicable):
Satellite 5.7.

How reproducible:
Always.

Steps to Reproduce:
1. Use Internet Explorer to login to a Satellite 5.7.
2. Observe the rendering at the top of the starting page /rhn/YourRhn.do
3.

Actual results:
Pages are not rendered properly in Internet Explorer with or without IE's compatibility mode.

Expected results:
Pages are rendered properly in Internet Explorer.

Additional info:
See attached screenshots.

Comment 1 Julio Entrena Perez 2015-02-25 17:28:03 UTC
Created attachment 995277 [details]
Internet Explorer 8 with compability mode

Comment 6 Grant Gainey 2015-03-03 17:14:15 UTC
[public so it can be searched later]

Testing with

IE 11.0.9600.17633
Update Versions: 11.0.16
Windows 7 SP1

breaks only if 'Compatibility Mode' (CM) is turned *on*.

Testing with

IE 11.0.9600.16428
Update Versions: RTM
Windows Server 2008 R2 Standard SP1

you cannot login (?!?) if CM is on. Once logged in, YourRhn.do page is broken until you turn CM *off*

The real bug is "Why does login fail unless CM is on, when running IE11 under Server 2008?"



Running IE11 on Win7 and logging in shows the following network traffic in the browser:

/rhn/LoginSubmit.do                  POST HTTPS 302
https://<sat5.7-fqdn>/rhn/YourRhn.do POST HTTPS 200

with the /var/log/httpd/ssl_(access,request)_log showing

==> ssl_access_log <==
xx.xx.129.125 - - [03/Mar/2015:12:09:52 -0500] "POST /rhn/LoginSubmit.do HTTP/1.1" 302 -

==> ssl_request_log <==
[03/Mar/2015:12:09:52 -0500] xx.xx.129.125 TLSv1.2 ECDHE-RSA-AES256-SHA384 "POST /rhn/LoginSubmit.do HTTP/1.1" -

==> ssl_access_log <==
xx.xx.129.125 - - [03/Mar/2015:12:09:52 -0500] "GET /rhn/YourRhn.do HTTP/1.1" 200 10493

==> ssl_request_log <==
[03/Mar/2015:12:09:52 -0500] xx.xx.129.125 TLSv1.2 ECDHE-RSA-AES256-SHA384 "GET /rhn/YourRhn.do HTTP/1.1" 10493



On reproducer IE11 on Server 2008, going to the same Sat5.7 instance, network-traffic in the browser is:

/rhn/LoginSubmit.do HTTPS POST 302
/rhn/YourRhn.do     HTTPS POST 302
https://<sat5.7-fqdn>/rhn/Login.do?url_bounce=/rhn/YourRhn.do&request_method=GET
                    HTTPS POST 200

with the server showing

==> ssl_access_log <==
xx.xx.20.211 - - [03/Mar/2015:12:07:25 -0500] "POST /rhn/LoginSubmit.do HTTP/1.1" 302 -

==> ssl_request_log <==
[03/Mar/2015:12:07:25 -0500] xx.xx.20.211 TLSv1.2 AES128-SHA256 "POST /rhn/LoginSubmit.do HTTP/1.1" -

==> ssl_access_log <==
xx.xx.20.211 - - [03/Mar/2015:12:07:26 -0500] "GET /rhn/YourRhn.do HTTP/1.1" 302 -

==> ssl_request_log <==
[03/Mar/2015:12:07:26 -0500] xx.xx.20.211 TLSv1.2 AES128-SHA256 "GET /rhn/YourRhn.do HTTP/1.1" -

==> ssl_access_log <==
xx.xx.20.211 - - [03/Mar/2015:12:07:26 -0500] "GET /rhn/Login.do?url_bounce=/rhn/YourRhn.do&request_method=GET HTTP/1.1" 200 5555

==> ssl_request_log <==
[03/Mar/2015:12:07:26 -0500] xx.xx.20.211 TLSv1.2 AES128-SHA256 "GET /rhn/Login.do?url_bounce=/rhn/YourRhn.do&request_method=GET HTTP/1.1" 5555


The problem is that third request, when running with CM off in IE11 on Server 2008.

Comment 7 Grant Gainey 2015-03-03 19:18:19 UTC
Adding the following Header to every response:

'X-UA-Compatible' = 'IE=edge,chrome=1'

appears to fix the 'broken with CM-on' display-issue. This may give us a workaround, since login works with CM-on, and the header fixes the breakage on the rest of the app. Investigation continues.

Comment 8 Grant Gainey 2015-03-03 19:59:18 UTC
NOTE re #6 - "you cannot login (?!?) if CM is on" should be "you cannot login (?!?) *unless* CM is on"

Comment 9 Grant Gainey 2015-03-05 18:23:07 UTC
Not having any luck understanding exactly what in IE11/compat-mode is breaking the login-page redirect. I am going to commit the fixes for the UI when under compatibility-mode for this BZ, in order to give relief to any affected users.

spacewalk.gitub 9e0d4dcccd244a5abc4d98e5891a45871f0ce4b7
spacewalk-version spacewalk-java-2.3.160-1

Comment 14 Lukáš Hellebrandt 2015-04-15 10:37:34 UTC
Verified with spacewalk-java-2.3.8-102 , spacewalk-web-2.3.2-32 ; note you also need to install satellite-schema-5.7.0.14-1

While it is still not possible to login with compatibility mode OFF, the UI has been fixed for CM ON which means it is not necessary to switch CM on and off anymore. According to devel, the bug is to be considered fixed.

If you need to use IE11, use it with CM set to ON for the Satellite WebUI.

Comment 16 errata-xmlrpc 2015-04-24 12:54:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0887.html


Note You need to log in before you can comment on or make changes to this bug.