Bug 119634 - /usr/share/automake-VERSION links are bad practice
Summary: /usr/share/automake-VERSION links are bad practice
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-switch-mail   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-31 22:49 UTC by Stig Hackvan
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 16:03:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stig Hackvan 2004-03-31 22:49:15 UTC
.src.rpms for many of the system-config-* packages have bogus and
unnecessary build-dependencies because of symlinks to automake helper
scripts. 

Please fix this.

I don't have a .spec file workaround for config-switch-mail because
the offending gunk is in system-switch-mail-0.5.24/po/Makefile:


MKINSTALLDIRS = /usr/share/automake-1.6/mkinstalldirs
mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo
"$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
 
-- stig

Comment 1 Ngo Than 2004-04-05 16:03:13 UTC
it's fixed in 0.5.25. thanks for your report


Note You need to log in before you can comment on or make changes to this bug.