Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1196384 - Can't modify a Service Request with a cloned 'approver' role
Summary: Can't modify a Service Request with a cloned 'approver' role
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.3.0
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: GA
: 5.4.0
Assignee: Brian McLaughlin
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks: 1196748
TreeView+ depends on / blocked
 
Reported: 2015-02-25 21:08 UTC by Jared Deubel
Modified: 2019-08-15 04:18 UTC (History)
7 users (show)

Fixed In Version: 5.4.0.0.11
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, request approvals were tied to a role name. As a result, when creating a new role by copying "EvmRole-approver" without changes, the new role was unable to see the provisioning request to approve it. This issue was fixed when the code was updated to allow MiQ request approval by feature rather than the role name. Service Request with a cloned "approver" role can view and approve the provisioning requests as expected, in the latest version of CloudForms Management Engine.
Clone Of:
: 1196748 (view as bug list)
Environment:
Last Closed: 2015-06-16 12:51:35 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1100 0 normal SHIPPED_LIVE CFME 5.4.0 bug fixes, and enhancement update 2015-06-16 16:28:42 UTC

Description Jared Deubel 2015-02-25 21:08:51 UTC
Description of problem:
Created a new role "myapprover" copying "EvmRole-approver" without changes, but myapprover user can't see provisioning requests.

Version-Release number of selected component (if applicable):
5.3.1.10

How reproducible:
Very 

Actual results:
Can't see provision requests

Expected results:
Should be able to approve or deny provision requests and have visibility.

Comment 2 CFME Bot 2015-02-26 16:20:59 UTC
New commit detected on manageiq/master:
https://github.com/ManageIQ/manageiq/commit/eab636faafaa1b3bfba427693940ff00b54a5822

commit eab636faafaa1b3bfba427693940ff00b54a5822
Author:     Brian McLaughlin <bmclaugh@redhat.com>
AuthorDate: Wed Feb 25 16:27:55 2015 -0500
Commit:     Brian McLaughlin <bmclaugh@redhat.com>
CommitDate: Wed Feb 25 16:30:09 2015 -0500

    Allow MIQ Request approval by feature rather than role name
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196384

 vmdb/app/controllers/miq_request_controller.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 4 Shveta 2015-03-12 22:02:11 UTC
Fixed .Approver role can see provisioning requests.
Verified in 5.4.0.0.11.20150309201930_8b6a235

Comment 6 errata-xmlrpc 2015-06-16 12:51:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1100.html


Note You need to log in before you can comment on or make changes to this bug.