Bug 119649 - Selinux, unable to login after kernel update (2.6.4~) via yum
Selinux, unable to login after kernel update (2.6.4~) via yum
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-doc (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Wade
:
Depends On:
Blocks: 118757
  Show dependency treegraph
 
Reported: 2004-03-31 22:50 EST by k l
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 17:37:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description k l 2004-03-31 22:50:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:

After using 'yum update' (from kernel-2.6.3-2.1.253.2.1 to
kernel-2.6.4-1.300) and rebooting, could not login to KDE as normal
user or root.  Gave an error about being unable to find home
directory, not being able to write to /, and that
"$test_filehome:ambiguous redirect".

Also, on command line, could not 'ls' in /mnt or /lost+found as normal
user, gave the flashing red text.

And, strangely, as root, did not have permission to save 'inittab'
from within nano.  Also could not 'touch' in /etc.  Saving to another
file, removing the original 'inittab', and then renaming new file to
'inittab' worked.

Version-Release number of selected component (if applicable):
kernel-2.6.4-1.300

How reproducible:
Always

Steps to Reproduce:
1. yum update from vanilla test2 system with KDE
2. reboot
3. try to login to KDE
    

Actual Results:  kicked back to gdm.

Expected Results:  able to login

Additional info:

I was able to circumvent this issue by setting 'SELINUX=disabled' in
/etc/sysconfig/selinux.  But, since selinux is now disabled, it's not
really a permament solution...  There must be some other selinux step
I'm missing that needs to be run after updating the kernel?
Comment 1 k l 2004-04-01 06:20:59 EST
this page explains this issue and a fix.

http://people.redhat.com/kwade/selinux/selinux-faq/selinux-faq-en/

"Q:. 	

I installed Fedora Core on a system with an existing /home partition,
and now I can't log in.
A:. 	

Your /home partition is not labeled correctly. You can fix this by
labeling /home correctly


/usr/sbin/setfiles /etc/security/selinux/file_contexts /home

You will need to have the policy-sources package installed to use
setfiles. Alternately, you can use the fixfiles utility to relabel
/home without having to install policy-sources. "

Basically this is not really a bug, but if I was a new user this would
be a major issue.
Comment 2 Karsten Wade 2004-08-25 17:37:31 EDT
Closing this as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.