Bug 1196539 - RHEL7.1 - Please ship perl-gettext package on ppc64/ppc64le/aarch64
Summary: RHEL7.1 - Please ship perl-gettext package on ppc64/ppc64le/aarch64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 7.4
Assignee: Lubos Kocman
QA Contact: Release Test Team
URL:
Whiteboard:
: 1205736 1213183 (view as bug list)
Depends On:
Blocks: 1134624 epel7ppc64le 1277314
TreeView+ depends on / blocked
 
Reported: 2015-02-26 08:35 UTC by Christopher Meng
Modified: 2017-12-02 15:46 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 17:29:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1850 normal SHIPPED_LIVE redhat-release update 2017-08-01 18:03:01 UTC
Red Hat Bugzilla 1134624 None None None Never
Red Hat Bugzilla 1443685 None None None Never

Internal Links: 1134624 1443685

Description Christopher Meng 2015-02-26 08:35:34 UTC
Building roxterm which requires po4a, failed at dependency issue in buildroot:

DEBUG util.py:366:  Getting requirements for roxterm-2.9.5-1.el7.src
DEBUG util.py:366:   --> dbus-glib-devel-0.100-7.el7.ppc64
DEBUG util.py:366:   --> desktop-file-utils-0.21-4.el7.ppc64
DEBUG util.py:366:   --> gtk3-devel-3.8.8-5.el7.ppc64
DEBUG util.py:366:   --> libglade2-devel-2.6.4-11.el7.ppc64
DEBUG util.py:366:   --> libSM-devel-1.2.1-7.el7.ppc64
DEBUG util.py:366:   --> libtool-2.4.2-20.el7.ppc64
DEBUG util.py:366:   --> po4a-0.45-3.el7.noarch
DEBUG util.py:366:   --> 1:python-lockfile-0.9.1-4.el7.noarch
DEBUG util.py:366:   --> vte3-devel-0.34.6-3.el7.ppc64
DEBUG util.py:366:   --> xmlto-0.0.25-7.el7.ppc64
DEBUG util.py:366:   --> 1:control-center-3.8.6-15.el7.ppc64
DEBUG util.py:366:  Error: Package: po4a-0.45-3.el7.noarch (build)
DEBUG util.py:366:             Requires: perl(Locale::gettext) >= 1.01
DEBUG util.py:366:   You could try using --skip-broken to work around the problem
DEBUG util.py:366:   You could try running: rpm -Va --nofiles --nodigest

Then we discussed this and found ppc64 doesn't include perl-gettext, I hope this can be fixed since po4a is required by many other packages.

Thanks.

Comment 1 Petr Pisar 2015-02-26 08:40:43 UTC
Please contact Red Hat Support to properly evaluate your request.

Comment 3 Petr Pisar 2015-03-26 06:58:12 UTC
*** Bug 1205736 has been marked as a duplicate of this bug. ***

Comment 6 Sergio Monteiro Basto 2015-05-08 13:52:02 UTC
*** Bug 1213183 has been marked as a duplicate of this bug. ***

Comment 7 Yaakov Selkowitz 2015-12-01 03:13:56 UTC
Both perl-gettext and perl-Text-WrapI18N are missing on aarch64, leading to the same issue when bootstrapping EPEL 7 there.

Comment 12 Yaakov Selkowitz 2016-11-04 19:34:11 UTC
Shipped in RHELSA 7.3 for aarch64.  Leaving open for ppc64*.

Comment 13 Lubos Kocman 2017-02-03 13:52:09 UTC
I'm giving this a devel_ack+ however, I'm bit afraid of what Peter said, if we'll hit missing dependencies on either aarch or ppc, we'll close this as won't fix

Lubos

Comment 16 Sergio Monteiro Basto 2017-02-06 04:33:51 UTC
(In reply to Lubos Kocman from comment #13)
> I'm giving this a devel_ack+ however, I'm bit afraid of what Peter said, if
> we'll hit missing dependencies on either aarch or ppc, we'll close this as
> won't fix


Hi , but #c12 says aarch64 is already fixed just left ppc64*.
Also, maybe anyone can suggest a better solution for po4a commit [1] ? 
What about ? 

%if 0%{?rhel} == 7 
# Until got perl-gettext on epel7-ppc64*
%ifnarch {%power64} 
Requires: perl(Locale::gettext) >= 1.01
%endif
%endif

%if 0%{?rhel} != 7
# Optional, but package is quite useless without
Requires: perl(Locale::gettext) >= 1.01
%endif


[1]
https://src.fedoraproject.org/cgit/rpms/po4a.git/commit/?id=95f9b406fff903235f9b9226aef718670e3d374f

Comment 26 Sergio Monteiro Basto 2017-05-31 11:11:00 UTC
FYI , we have po4a to fix as next step [1] , have you built also po4a on ppc64/ppc64le ? and on aarch64 ? 

[1] https://lists.fedorahosted.org/archives/list/epel-devel@lists.fedoraproject.org/thread/VTFST27CHFDBQF4TAOWZAOTCMGE44HKJ/?sort=date

Comment 27 errata-xmlrpc 2017-08-01 17:29:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1850

Comment 28 Fedora Update System 2017-12-02 15:46:14 UTC
po4a-0.52-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-40776a60b5


Note You need to log in before you can comment on or make changes to this bug.