Bug 1196615 - [dht]: Failed to rebalance files when a replica-brick-set was removed
Summary: [dht]: Failed to rebalance files when a replica-brick-set was removed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raghavendra G
QA Contact:
URL:
Whiteboard:
: 1196775 (view as bug list)
Depends On: 1196029 1196775
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-26 11:38 UTC by Raghavendra G
Modified: 2015-05-14 17:46 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1196029
Environment:
Last Closed: 2015-05-14 17:29:11 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Raghavendra G 2015-02-26 17:33:11 UTC
*** Bug 1196775 has been marked as a duplicate of this bug. ***

Comment 2 Anand Avati 2015-02-26 17:34:59 UTC
REVIEW: http://review.gluster.org/9764 (cluster/dht: Allow fix layout during brick decommission) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 3 Anand Avati 2015-03-03 12:01:59 UTC
REVIEW: http://review.gluster.org/9764 (cluster/dht: Fixes to should_fix_layout logic) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 4 Anand Avati 2015-03-04 04:51:46 UTC
COMMIT: http://review.gluster.org/9764 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit ef061b67f1b80c147c1959b896f7c9bdff01af96
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Thu Feb 26 22:50:25 2015 +0530

    cluster/dht: Fixes to should_fix_layout logic
    
    * With recent introduction of locking in self-heal codepath,
      fix layout was not allowed to progress during remove-brick.
      This patch fixes the issue.
    
    * dht_should_fix_layout also considers "dir-spread-count" option if
      set, to determine whether we should proceed with fix-layout or not.
    
    Change-Id: Icd96986f7af705744131d62e7f1456114ac1ee53
    BUG: 1196615
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/9764
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>

Comment 5 Anand Avati 2015-03-05 08:57:04 UTC
REVIEW: http://review.gluster.org/9809 (cluster/dht: fixes to should_layout_fix logic) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 6 Anand Avati 2015-03-05 11:19:09 UTC
REVIEW: http://review.gluster.org/9809 (cluster/dht: fixes to should_layout_fix logic) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 7 Anand Avati 2015-03-05 15:00:55 UTC
REVIEW: http://review.gluster.org/9809 (cluster/dht: fixes to should_layout_fix logic) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 8 Anand Avati 2015-03-05 18:03:34 UTC
COMMIT: http://review.gluster.org/9809 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit e944ff1f5a187863343691dfc108237c10dde287
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Thu Mar 5 14:23:38 2015 +0530

    cluster/dht: fixes to should_layout_fix logic
    
    * Don't consider "dir-spread-count" option. This option is not
    supported.
    * Consider transition to weighted to equal distribution or vice-versa
    a valid case for fixing the layout.
    
    Change-Id: I0dcfe555dae9269ce20a41611cfdaa4f96c9e98b
    BUG: 1196615
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/9809
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 9 Niels de Vos 2015-05-14 17:29:11 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 10 Niels de Vos 2015-05-14 17:35:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 11 Niels de Vos 2015-05-14 17:38:13 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 12 Niels de Vos 2015-05-14 17:46:00 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.