Bug 119663 - System stops after first start (monitor blanks and hd stops) on Dell Inspiron 8600 with Ati Radeon 8600 Pro Turbo
System stops after first start (monitor blanks and hd stops) on Dell Inspiron...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-01 02:41 EST by Alexander Kogler
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-22 11:31:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexander Kogler 2004-04-01 02:41:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
After the first start where you have to select soundcard / username
and so on, the system stops. This error is hard to describe, because I
don't get any information from the machine anymore. The monitor is
suddenly black and the harddisk stops working.

After pushing the power button for 4 seconds and restarting, the
system stops with the same symtoms after setting the hostname. Its
going so fast that I cannot click on details to see what he is doing

I tried starting with "noapic" and "nofb" but the symtoms are the
same. WLAN and Bluetooth where disabled with FN+F2

System:
Dell Inspiron 8600
Intel Pentium M 1700, 512mb ram, Ati Radeon 8600 Pro Turbo (128MB),
Broadcom 440x 10/100 Integrated Controller (LAN)
Dell TrueMobile 1300 WLAN Mini-PCI Karte
HL-DT-ST DVD+RW GCA-4040N


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core 2 Test 2 :)
2.
3.
    

Actual Results:  Same results ... I tried it 3 times (with different
install options and grafic resolutions

Expected Results:  A working System ? or at least a console to debug

Additional info:

I saw a lot of fedora core1 installation instructions on the web, but
all had the nvidia geforce go chip instead of the ati radeon chip ..
this might be the difference ?
Comment 1 yuval aviel 2004-04-01 09:24:36 EST
I had similar simptoms. I have HP nx9000 with Radeon AGP 340M video card. 
In addition to the above - the keybard hungs as well.
It got even stranger when I succeeded to have X (kde and gnome)
running after a few tries (first init level 1, then 3 and then it
worked for good!)

This is not all, when rebooting - the computer hungs also. 
None of these happened in FC2 T1.
Comment 2 Chen Nan 2004-04-01 10:24:19 EST
A similar but different problem here.

I didn't encounter any problem during installation. My ATI 9200 card
was correctly detected.

After installation, X hang when trying to start firstboot. Background
image corrupted, but mouse can move. Ctrl-Alt-Backspace doesn't work.
The only way out is the hardware reset button.

I downloaded latest driver from ATI website and force installed it
(with some conflicts with the stock display driver). Despite the
errors shown during the installation, X works now. I am right now
typing in Mozilla Firefox running on FC2 Test2. :)

My hardware:
Athlon XP 2500+
ABit NF7-S (nForce2)
DDR 400 RAM
ATI Radeon 9200
Comment 3 Alexander Kogler 2004-04-01 13:16:21 EST
The Problems you have doesn't seem to have something to do with my
problem. I don't have any chance to get to the console or do something
e lse (like installing the ati driver) because the system hangs at
startup after setting the hostname (this is the last thing I can read
on the loading screen before the system stops).
The Display blackens, the harddisk is doing nothing and the keyboard
doesn't react at all .. a (hmm) black screen of death :).

I tried to set higher resolutions after firststart (like 1400x1050 (i
didn't find 1680x1050 in the monitor section <- would be a request for
the final)). After restart it uses the higher resolution (for about 4
or 5 seconds in the loadingscreen (and then blackens again :(
Comment 4 Chen Nan 2004-04-01 21:31:44 EST
Well, I didn't get any chance to log into the console either, as
"firstboot" is part of the boot sequence. I used a trick. As I have
RH9 installed on the same machine, I booted into RH9, mount the FC2
partition and edit the XF86Config to change video driver from "radeon"
to "vesa". This caused X to crash instead of hang. That gave me a
chance to login in console mode and force install the ATI driver.

The proper way should be using some kernel parameter or key press
during boot up to boot into console mode or single user mode directly.
You can google a bit on that.
Comment 5 Joshua 2004-04-13 02:54:13 EDT
I am having the exact same problem, but i have an Acer Aspire 1501 
which uses an ATI mobility Radeon 9600 64mb

the install was fine, but after the user setup and the sound 
settings, i get a black screen.
using Fedora Core 2 Test 2
i am not using the ATI driver but instead the vesa, since i've had 
bad luck with the ati driver in the past.
i set the res to 1400x1050 which is the res for my lcd.

to get around this problem i used the install cd and did a rescue, 
change the inittab to boot into runlevel 3 instead
now i get a console login, and i can run x, as root only...

but if i logoff then the same thing happens, black screen and the 
system pretty much stops
Comment 6 Need Real Name 2004-04-28 08:15:41 EDT
I also observed X-crashes right after installing FC2-test2 on an Acer
Aspire 1501 - ATI mobility Radeon 9600 64mb. No matter what resolution 
I tried to enforce. Installing Fedora1 worked like a charm since there
the SVGA X-server works just fine up to 1400x1050. I hope the SVGA
issue is fixed since no one can tell when ATI comes up with
proprietary drivers which are compatible the latest X version *and* 
the 2.6.x kernel. Btw. X didn't completely crash the machine. The
screen went black and I couldn't go back to the console. However,
Ctrl-Alt-Del
still caused a 'clean' shutdown.
Comment 7 Mike A. Harris 2004-12-22 11:31:25 EST
This was mis-filed against "XFree86" which doesn't exist in
FC2.  X.Org replaced XFree86 in FC2 and all newer OS releases.
"xorg-x11" is the correct component.


In reply to comment #6:
>I tried to enforce. Installing Fedora1 worked like a charm since
>there the SVGA X-server works just fine up to 1400x1050. I hope the
>SVGA issue is fixed since no one can tell when ATI comes up with

There is only one X server in Red Hat Linux 8 and newer OS releases,
the XFree86 server in RHL 8 and 9, and FC1, and X.Org X server
in FC2 and newer.  There is no "SVGA" X server included in Red Hat
OS products since Red Hat Linux 7.3.  The SVGA X server is actually
named XF86_SVGA and was part of XFree86 3.3.6 which last shipped
in RHL 7.3.

Not sure where you got SVGA server from, but was not part of any
Fedora Core release, and our XFree86 and Xorg packages explicitly
flag the older X servers as "Obsoltes" which will cause them to
be forcibly removed even on upgrades from older OS's.




Having said all that, Radeon 9600 is not supported officially
until Fedora Core 3 in X.Org X11 6.8.1.  In Fedora Core 2 it
was unsupported but the driver had experimental code for it that
worked for some people.  In FC1, it was totally unsupported.

In that case, the solution is to upgrade to FC3 in order to get
proper Radeon 9600 support.

Hope this helps.

Setting status to "CURRENTRELEASE"

Note You need to log in before you can comment on or make changes to this bug.