Bug 119667 - (DRI SIS)Tuxracer crashes the machine
(DRI SIS)Tuxracer crashes the machine
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-01 04:18 EST by Eugenia Loli-Queru
Modified: 2015-01-04 17:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 01:41:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugenia Loli-Queru 2004-04-01 04:18:03 EST
Description of problem:
I launched Tuxracer and my machine is now crashed. The only thing I 
can do is move around the mouse on a black screen, while the keyboard 
is dead. There is nothing else I can do.

Please note that I don't have 3D acceleration on this machine, it has 
an SiS 750 integrated graphics card running at 1280x1024x24bpp at 
85Hz, as 2D-only. There is no DRI for SiS cards.

Unfortunately I can't SSH into that machine to learn more, as it gets 
its IP dynamically so i don't know its IP.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run Tuxracer on a machine with an SiS card
2.
3.
    

Additional info:
Comment 1 Ngo Than 2004-04-01 05:15:14 EST
tuxracer needs DRI, it does not work without it.
Comment 2 Eugenia Loli-Queru 2004-04-01 15:30:31 EST
Ngo, you got to be joking. You closed this bug??

So, are you telling me that you include an application on your 
product that can completely crash a machine under a specific 
condition, while this specific condition is very common among most 
users: ATi, nVidia, SiS, Trident, some Matrox models and many models 
of S3 don't come with DRI support bundled with your operating system, 
while there are cases that even the user would download a DRI from 
nvidia/ATi site, there is a good chance that there won't be any 
supported version for your specific kernel verison available to 
download.

The real point though is that no application -- for no reason 
whatsoever-- should crash a machine (I can accept driver crashes 
because it is a reality that hardware companies are not so brilliant 
writing drivers (e.g. Creative or Epson), and that's about it). In my 
case actually, I clicked on "tuxracer" by mistake, I wanted to load  
the "Same Gnome" game from the games menu. And I was treated with a 
total machine crash.

Here's a clue: the game should have produced an alert/assert saying 
that it was not able to initialize DRI or OpenGL. This is exactly 
what happens on my Windows XP machine when I run a brand new 3D game 
that my aged Matrox G400 can't handle. But under *no circumstances* I 
get an OS crash, ever.

If a game crashes the whole OS just because it can't initialize GL or 
DRI and then you close that report as "what did you expect?", I see 
that your company has a lot of maturity to do yet in the marketplace.

If you are not willing to fix it, then do not include this game with 
your product. Most of the people are not bothering of installing 
third party DRIs anyway and yourselves don't include nvidia & Ati 
closed source DRI drivers, so I don't see why you would need to 
jeopardize the stability of most people's PCs with a brain-dead 
application.
Comment 3 Eugenia Loli-Queru 2004-04-01 15:41:23 EST
And BTW, I have ran Tuxracer on my Slackware with an nvidia card 
*without* DRI installed, and it loaded fine, it was just painfully 
slow because it was unaccelerated.
The real bug here is that Tuxracer does not load itself in any GL 
mode available to the system, it just hangs when the accompanied 
graphics card is an SiS. I had success using Tuxracer with MESA when 
the graphics card was Nvidia and Voodoo5 (unaccelerated too). So the 
meat of the bug here is "SiS gfx card with Tuxracer don't go well 
together".
Comment 4 Eugenia Loli-Queru 2004-04-01 16:06:21 EST
>> I had success using Tuxracer with MESA when the graphics card was 
Nvidia and Voodoo5 (unaccelerated too).

On different machines/distros that is.
Comment 5 Ngo Than 2004-04-02 06:43:51 EST
i know that tuxracer works without DRI, but it's too slow then, and
it's not playable.

The problem which crashes your machine, could be a driver bug in  
X. could you please mail me the backtrace?
Comment 6 Ngo Than 2004-04-02 07:29:31 EST
please try to start glxinfo. What does it say or just crashes X?
Comment 7 Eugenia Loli-Queru 2004-04-02 14:08:35 EST
> What does it say or just crashes X?

As I mentioned multiple times in my bug report, the whole OS/machine 
crashes, not just X. There is no way to get a backtrace, it is a hard 
crash.
Comment 8 Eugenia Loli-Queru 2004-04-02 14:12:50 EST
>please try to start glxinfo.

Complete hard crash. Black screen and everything, only thing I can do 
is reset the machine.
Comment 9 Bill Nottingham 2004-04-02 18:23:01 EST
There is SiS DRM for some cards. Assigning to kernel.
Comment 10 Arjan van de Ven 2004-04-03 02:14:48 EST
is there any info in /var/log/messages or other kind of oops information ?
Comment 11 Eugenia Loli-Queru 2004-04-05 19:58:01 EDT
Except 6 MB worth of the following, no. (I will be filing another bug 
report for that :P):

Apr  5 16:39:12 duron fam[3103]: listen: Permission denied
Apr  5 16:39:12 duron kernel: audit(1081208352.562:0): avc:  denied  
{ search } for  pid=3104 exe=/usr/bin/fam name=sys dev=Untitled 1 
ino=4120 scontext=system_u:system_r:inetd_child_t 
tcontext=system_u:object_r:sysctl_t tclass=dir
Apr  5 16:39:12 duron fam[3104]: listen: Permission denied
Apr  5 16:39:12 duron kernel: audit(1081208352.564:0): avc:  denied  
{ listen } for  pid=3104 exe=/usr/bin/fam path=/tmp/.fam_socket 
scontext=system_u:system_r:inetd_child_t 
tcontext=system_u:system_r:inetd_child_t tclass=unix_stream_socket

Anywhere else I could look?
Comment 12 Alex Dennis 2004-05-18 15:51:21 EDT
I'm not sure if it's the 'same' problem, but Tuxracer crashes my
machine too. It runs for a few seconds then stops altogether (no
music, no movement, keyboard and mouse unresponsive). I'm using a
Matrox G450 which has worked with Tuxracer in the past (FC1), Athlon
processor. I'm happy to crash the machine again if the crash will
generate something that'll be useful. It's my home machine, not
networked, dial-up access only.

Anything I can do that will provide more information? I'm running FC2
final -- just installed so playing around.
Comment 13 Dave Jones 2004-12-08 00:54:36 EST
is this any better with the current updates / release ?
Comment 14 Eugenia Loli-Queru 2004-12-08 01:18:24 EST
dunno, won't try fedora on that machine again.

Note You need to log in before you can comment on or make changes to this bug.