Bug 1196673 - task list page is very slow
Summary: task list page is very slow
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Tasks Plugin
Version: 6.0.8
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Chris Duryee
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2015-02-26 13:57 UTC by Peter Vreman
Modified: 2019-09-25 21:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:13:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1163740 None None None Never
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Internal Links: 1163740

Description Peter Vreman 2015-02-26 13:57:19 UTC
Description of problem:
The tasks list is slow. It takes a while to find all tasks:

   Displaying entries 1 - 50 of 10026 in total

With the oldest tasks being 5 months old:

Create user 'API Admin' 	stopped 	success 	2014-09-18 08:43:18 UTC 	
Create user 'Anonymous Admin' 	stopped 	success 	2014-09-18 08:43:17 UTC


Please limit the default view of the task list to a relevant time range of 24h.
Have an UI element quickly change the relevant time range in easy steps:

Last 2h
Last 6h
Last 12h
Last 24h
Last 2d
Last 7d
Last 30d
All

This limit in timestamp shall also improve the performance of the tasks list




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create 10000+ tasks
2. List Tasks
3.

Actual results:
Slow loading of the data. Many pages available.

Expected results:
Only relevant tasks in the specified time range.


Additional info:

Comment 1 RHEL Program Management 2015-02-26 20:17:45 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Chris Duryee 2016-03-07 16:40:09 UTC
I tested the speed of the tasks page on Satellite 6.1 and 6.2 (snapshot version):

on 6.1: /foreman_tasks/tasks for 96 tasks, pagination of 20 takes 4692ms
        /foreman_tasks/tasks for 96 tasks, pagination of 10,000 takes 15426ms

on 6.2: /foreman_tasks/tasks for 2035 tasks, pagination of 20 takes 1103ms
        /foreman_tasks/tasks for 2035 tasks, pagination of 10,000 takes 53606ms

I saw similar improvement on a Katello 2.4 installation with >3000 tasks, pagination of 20.

I am investigating more now to see what caused the improvement.

Comment 4 Chris Duryee 2016-03-07 16:59:24 UTC
This appears to be addressed via an index that was added to the DB.

Comment 5 Chris Duryee 2016-03-07 17:07:07 UTC
Peter,

I believe this bug was addressed by adding an index to the tasks table, which sped things up significantly. I think this makes the dropdown with default of 24h not needed anymore, but if you disagree please reply back to this BZ. Thanks!

Comment 9 Jitendra Yejare 2016-04-27 09:49:57 UTC
Verified !

@ Sat 6.2 Snap 9.2

I tested this with 4493 tasks in 225 pages with 20 entries per page.
Its loading the tasks in expected/reasonable time.

So, moving the bz to verified.

Comment 11 errata-xmlrpc 2016-07-27 09:13:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.