Bug 1196690 - Dist-geo-rep: setxattr to files on master are not getting synced to slave
Summary: Dist-geo-rep: setxattr to files on master are not getting synced to slave
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On: 1056226
Blocks: 1035040
TreeView+ depends on / blocked
 
Reported: 2015-02-26 14:36 UTC by Aravinda VK
Modified: 2015-05-14 17:35 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.7dev-0.821.git0934432.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 1056226
Environment:
Last Closed: 2015-05-14 17:26:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2015-02-26 14:36:56 UTC
+++ This bug was initially created as a clone of Bug #1056226 +++

Description of problem: setxattr to files on master are not getting synced to slave. 

changelog which was processed had entries like 

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
M a618669b-69ef-4199-809d-b2d662980dce SETXATTR
M 90c30f79-f091-48d7-9584-676fbefbddaa SETXATTR
M 80817904-2143-4645-88e5-328e9f52d310 SETXATTR
M 6758006f-82fe-412c-8863-05683172628a SETXATTR
M fc557052-9a4f-45b8-9cda-917619a1708e SETXATTR
M 489cc22b-80d7-457f-9ed3-536ac46d3df3 SETXATTR
M 63049cc0-1c68-482b-8a85-6e39b2ff63b1 SETXATTR
M 0c57c18a-3955-4605-9f4a-f8c10435b6b1 SETXATTR
M df2843c9-9831-4da5-8ede-ad4bcffa6aa8 SETXATTR
M 9e641774-de31-4de8-9975-82d81c705c53 SETXATTR
M 837802d1-3113-495b-ad1d-c13c892c2c37 SETXATTR
M 975beeb9-d516-40a8-bff5-9955765d6204 SETXATTR
M 3c96b2c0-5652-4f1e-82a6-59fb8e77047d SETXATTR
M d327936f-17f6-4892-b8c2-98c022749fd2 SETXATTR
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

on master
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
# file: mnt/master/52dea336%%ZHPQYIOVY3
trusted.glusterfs.205daa96-ff92-45be-96bc-3e6bd5c0f631.xtime=0x52dea3aa0001b9c2
user.0ZIVS7PBZA=0x305a4956533750425a41

# file: mnt/master/52dea336%%ZRY5O1R2XO
trusted.glusterfs.205daa96-ff92-45be-96bc-3e6bd5c0f631.xtime=0x52dea3a9000d6c6b
user.9CKK8JTO73=0x39434b4b384a544f3733
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

on slave 
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
[root@redmoon ~]# getfattr -d -m . -e hex /mnt/slave/52dea336%%MQLE79PX49
[root@redmoon ~]# 
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Version-Release number of selected component (if applicable):glusterfs-geo-replication-3.4.0.57rhs-1


How reproducible: Happens everytime 


Steps to Reproduce:
1.create and start a geo-rep relationship between master and slave.
2.create some data on master.
3.do setxattr on master on created data, and check if it gets synced to slave. 

Actual results: setxattr to files on master are not getting synced to slave 

Expected results: setxattrs are also supposed to sync to slave.

Comment 1 Anand Avati 2015-02-26 15:03:20 UTC
REVIEW: http://review.gluster.org/9499 (geo-rep: Add support for xattrs) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Anand Avati 2015-03-02 10:06:00 UTC
COMMIT: http://review.gluster.org/9499 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 1455ee40030c8d3c4818ba7d7ca8ca851e12b848
Author: Aravinda VK <avishwan@redhat.com>
Date:   Wed Jan 28 17:19:42 2015 +0530

    geo-rep: Add support for xattrs
    
    This patch adds support for xattrs. When it sees SETXATTR
    in Changelog, it adds the file to data queue. rsync/tar+ssh
    will take care of syncing xattrs. User set xattrs will be
    synced to Slave.
    
    New config interface is introduced, sync-xattrs
    Which can be set using geo-rep config(Default is True)
    
    gluster volume geo-replication <VOLUME> <SLAVEHOST>::<SLAVEVOL> \
                   config sync-xattrs false
    
    Change-Id: I70626d854a0d616469dd54d61e5ef155ed8b67d8
    BUG: 1196690
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/9499
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 3 Niels de Vos 2015-05-14 17:26:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 4 Niels de Vos 2015-05-14 17:28:25 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:35:16 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.