Bug 1196705 - libguestfs requires selinux-policy, but selinux-policy should be optional
Summary: libguestfs requires selinux-policy, but selinux-policy should be optional
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-26 15:00 UTC by Richard W.M. Jones
Modified: 2015-11-19 06:59 UTC (History)
4 users (show)

Fixed In Version: libguestfs-1.28.1-1.25.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 06:59:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2183 0 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2015-11-19 08:18:42 UTC

Description Richard W.M. Jones 2015-02-26 15:00:18 UTC
Description of problem:

Currently libguestfs has a hard dependency on selinux-policy.

This was added to enforce a minimum version of SELinux that
supported sVirt.  That's valuable, but selinux-policy should
be optional.

We should replace this with:

  Conflicts: selinux-policy < [version]

Version-Release number of selected component (if applicable):

libguestfs since 1.20

How reproducible:

100%

Steps to Reproduce:
1. yum install libguestfs
2. yum remove selinux-policy

Actual results:

Removing selinux-policy will remove libguestfs.

Expected results:

It should be possible to remove selinux-policy (or not
install it) without affecting libguestfs.

Additional info:

Comment 1 Richard W.M. Jones 2015-04-13 15:05:51 UTC
In the end I just dropped the 'Requires selinux-policy' line entirely,
since it refers to a very old version of SELinux (circa 2012).

Comment 3 Hu Zhang 2015-05-06 07:00:40 UTC
Verified with libguestfs-1.28.1-1.29.el7.

Steps to verify:
1. yum install libguestfs
2. yum remove selinux-policy
Loaded plugins: langpacks
Resolving Dependencies
--> Running transaction check
---> Package selinux-policy.noarch 0:3.13.1-23.el7 will be erased
--> Processing Dependency: selinux-policy = 3.13.1-23.el7 for package: selinux-policy-targeted-3.13.1-23.el7.noarch
--> Processing Dependency: selinux-policy = 3.13.1-23.el7 for package: selinux-policy-targeted-3.13.1-23.el7.noarch
--> Running transaction check
---> Package selinux-policy-targeted.noarch 0:3.13.1-23.el7 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================
 Package                              Arch                Version                       Repository                  Size
=========================================================================================================================
Removing:
 selinux-policy                       noarch              3.13.1-23.el7                 @anaconda/7.1              176  
Removing for dependencies:
 selinux-policy-targeted              noarch              3.13.1-23.el7                 @anaconda/7.1               10 M

Transaction Summary
=========================================================================================================================
Remove  1 Package (+1 Dependent package)

Installed size: 10 M
Is this ok [y/N]: 

Removing selinux-policy will not affect libguestfs. So fixed.

Comment 5 errata-xmlrpc 2015-11-19 06:59:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2183.html


Note You need to log in before you can comment on or make changes to this bug.