Bug 119671 - up2date does not work in enforcing mode on SELinux
up2date does not work in enforcing mode on SELinux
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks: up2date-fc2 122683
  Show dependency treegraph
 
Reported: 2004-04-01 07:58 EST by Daniel Walsh
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 21:54:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2004-04-01 07:58:47 EST
Description of problem:
up2date is not running under a context that allows it to install rpm
files.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to run up2date
2.
3.
  
Actual results:


Expected results:


Additional info:
You need to modify /etc/security/console.apps/up2date

USER=root
PROGRAM=/usr/sbin/up2date
NOXOPTION=--nox
SESSION=true
ROLE=sysadm_r
TYPE=rpm_t

ROLE and TYPE will cause up2date to run with the rpm_t policy and
allow it to install rpm's on a SELinux box.  If the box
is not SELinux these fields will be ignored.

Could you add them to the up2date package.

>
Comment 1 Chen Nan 2004-04-01 10:11:39 EST
I don't know whether this is the same issue, but for my case up2date
couldn't even run.

If I start up2date as a normal user, I get the following error after
entering root password:
"Could not set exec context to user_u:sysadm_r:sysadm_t."

If I start update as root user, it runs.
Comment 2 Steve Ward 2004-04-01 21:45:26 EST
I tried making the change recommended, it had no effect.
Comment 3 Chen Nan 2004-04-02 21:16:31 EST
I tried to modify "/etc/security/console.apps/up2date" to add the
following lines as recommended by the bug reporter:

ROLE=sysadm_r
TYPE=rpm_t

I got the following error:

[chennan@localhost chennan]$ up2date
Could not set exec context to user_u:rpm_t:sysadm_r.
Broken pipe
Comment 4 Daniel Walsh 2004-04-03 00:24:06 EST
You need to update the usermode package and grab the latest policy files.
Comment 5 Adrian Likins 2004-04-05 15:00:18 EDT
committed to cvs, 4.3.15 or higher should have it
Comment 6 Carlos 2004-04-06 12:36:53 EDT
running uptodate stated there was an ethereal dependency problem..
after rebooting i got to:
halted
Kernel Panic: attempted to kill init!
to fix this i had to boot into rescue mode...and edit the following:
/etc/sysconfig/selinux
this originally read:
SELINUX=enforcing
in order to boot my system I changed it to:
SELINUX=disabled
then had to:
chroot /mnt/sysimage
to get back into fedora core 2 test 2

hope this info helps... just reporting my similar problem.
Comment 7 Noa Resare 2004-04-09 16:57:23 EDT
Initially I had the same problem as #3 above, but upgrading to
policy-1.10.1-4 and kernel-2.6.5-1.308 from the development tree on an
otherwise blank fc2test2 resolves this.

My recomendation would be to close this as RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.