Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1196713 - thermostat depends on jetty, but not on thermostat-webapp
thermostat depends on jetty, but not on thermostat-webapp
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: thermostat (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Severin Gehwolf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-26 10:09 EST by Severin Gehwolf
Modified: 2015-03-31 18:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: thermostat-1.2.2-5.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-31 18:01:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Severin Gehwolf 2015-02-26 10:09:39 EST
Description of problem:
When installing thermostat in F22/rawhide it drags in jetty dependencies due to "thermostat web-storage-service". However, there is no guarantee that the webapp itself (which "thermostat web-storage-service" needs) is installed.

Version-Release number of selected component (if applicable):
thermostat-1.2.0-13.fc22.x86_64

How reproducible:
100%

Steps to Reproduce:
1. yum erase thermostat\*
2. yum install thermostat

Actual results:
Step two drags in jetty deps.

Expected results:
No jetty deps get installed. The web-storage-service plugin should not get installed.

Additional info:
web-storage-service should be moved to package thermostat-webapp or into a separate sub-package which then depends on thermostat-webapp. The most clean solution would be to only have the webapp in thermostat-webapp (with no tomcat deps). Then add other sub-packages which either drag in tomcat or jetty. Whatever the user wants.

There is one more problem: thermostat-setup assumes the webapp is installed (for changing WEB-INF/web.xml) which might not be the case.
Comment 1 Severin Gehwolf 2015-03-24 13:35:59 EDT
Fixed with thermostat-1.2.2-5.fc22:
http://koji.fedoraproject.org/koji/buildinfo?buildID=623235
Comment 2 Severin Gehwolf 2015-03-24 13:36:37 EDT
web-storage-service is now part of thermostat-webapp.
Comment 3 Fedora Update System 2015-03-24 13:58:46 EDT
thermostat-1.2.2-5.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/thermostat-1.2.2-5.fc22
Comment 4 Fedora Update System 2015-03-26 18:03:17 EDT
Package thermostat-1.2.2-5.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing thermostat-1.2.2-5.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4702/thermostat-1.2.2-5.fc22
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2015-03-31 18:01:28 EDT
thermostat-1.2.2-5.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.