Bug 1196725 - CLI - removing a role just prints the plan-show output
Summary: CLI - removing a role just prints the plan-show output
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tuskarclient
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Director
Assignee: Brad P. Crochet
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-26 15:34 UTC by Ola Pavlenko
Modified: 2015-08-05 13:50 UTC (History)
6 users (show)

Fixed In Version: python-tuskarclient-0.1.17-3.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:50:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 173026 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Ola Pavlenko 2015-02-26 15:34:07 UTC
Description of problem:
Removing a role from a plan using CLI only prints the output of plan-show .
It doesn't remove the role

Version-Release number of selected component (if applicable):
$ rpm -qa | grep tuskar
openstack-tuskar-ui-0.2.0-11.el7ost.noarch
openstack-tuskar-ui-extras-0.0.3-1.el7ost.noarch
openstack-tuskar-0.4.15-4.el7ost.noarch
python-tuskarclient-0.1.15-3.el7ost.noarch


How reproducible:

always

Steps to Reproduce:
1. choose a role UUID
2. Remove the role from the plan 
tuskar plan-remove-role -r 08a826f0-e601-49b8-b5fc-548b04a4e84d 511dbc02-439b-4bda-9df7-d987cd19cbcc

Actual results:

prints plan-show output only

Expected results:
the role was removed from the plan


Additional info:

Comment 3 Ola Pavlenko 2015-02-26 15:46:33 UTC
same behavior for plan-add-role

Comment 4 Ola Pavlenko 2015-02-26 16:29:50 UTC
ignore Comment#3

the role will be added in case it doesn't exist in the plan already.

Comment 5 Brad P. Crochet 2015-04-13 18:10:53 UTC
Review available upstream:

https://review.openstack.org/173026

Comment 6 Ana Krivokapic 2015-06-01 08:28:33 UTC
Upstream patch merged.

Comment 12 errata-xmlrpc 2015-08-05 13:50:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.