Bug 1196757 - [RFE][UI] Cannot override image's name when importing an image from glance from the webadmin
Summary: [RFE][UI] Cannot override image's name when importing an image from glance fr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Idan Shaby
QA Contact: Elad
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-26 16:33 UTC by Tareq Alayan
Modified: 2016-03-09 20:58 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this release, you can edit the alias of a disk image in the Import Image view when importing an image from Glance. Without the ability to change the alias, each import of the same image creates a disk with the same name (which is the default name for that disk). Now, an editable column named "Disk Alias" was added to the table of images which were chosen to be imported. Each image has its own default name, which has not changed and can be left as is. However, one can now edit each image alias before the import.
Clone Of:
Environment:
Last Closed: 2016-03-09 20:58:32 UTC
oVirt Team: Storage
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 41394 master MERGED core, webadmin: Override image name in import image view Never

Description Tareq Alayan 2015-02-26 16:33:03 UTC
Description of problem:
Currently you can't change name of image in the glance import dialogue when importing it from glance.

Version-Release number of selected component (if applicable):
rhevm-3.5.0-0.31.el6ev.noarch

How reproducible:
always

Steps to Reproduce:
1. Have a glance connected to your engine and have images in it
2. import an image; A pop up will appears without the possibility to modify the disk name.

Actual results:
Disk name is GlanceDisk-e88ca9b

Expected results:
possibility to override the disk name 

Additional info:
every time you import the same disk you will get the same disk name on the rhevm.

Comment 1 Tareq Alayan 2015-02-26 16:40:45 UTC
Note that when you choose to import the image as template you cannot decide the template name.

Comment 2 Allon Mureinik 2015-02-27 12:26:21 UTC
Daniel, does the work you did on bug 1169224 solve this one too?

Comment 4 Daniel Erez 2015-02-28 16:49:13 UTC
(In reply to Allon Mureinik from comment #2)
> Daniel, does the work you did on bug 1169224 solve this one too?

No. bz1169224 was an RFE merely for the rest-api.

Comment 6 Allon Mureinik 2015-06-11 12:23:10 UTC
Idan - this is new functionality. Please provide some doctext for it.

Comment 7 Allon Mureinik 2015-06-17 07:53:02 UTC
Idan, what does this doctext have to do with importing an image from glance?

Comment 8 Idan Shaby 2015-06-17 08:51:12 UTC
Sorry, confused with another bug.

Comment 9 Max Kovgan 2015-06-28 14:13:14 UTC
ovirt-3.6.0-3 release

Comment 10 Elad 2015-07-08 08:30:53 UTC
Verified using:
Tested using ovirt3.6.0-3
ovirt-engine-3.6.0-0.0.master.20150627185750.git6f063c1.el6.noarch

Test run executions:

https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/workitem?id=RHEVM3-10686

https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/workitem?id=RHEVM3-10689

Comment 12 errata-xmlrpc 2016-03-09 20:58:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.